ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Does Ant's version 1.4.1 support Java's jdk1.1.8?
Date Thu, 31 Jan 2002 16:44:26 GMT
On Thu, 31 Jan 2002, Diane Holt <holtdl@yahoo.com> wrote:

> My approach has always been to use the latest&greatest JDK, so you
> get the faster/better Java executables, and if you need to compile
> against old crud, just pass it the old classes.

This doesn't work in all circumstances, the depend attribute is one
example: if you use JDK >= 1.3 it will be a NOOP, if you are running
on JDK 1.2, Ant will send the -Xdepend switch, no matter which classes
will be used.

The debug switch and classpath handling are also different if your Ant
is running on a JDK 1.2 or 1.1.  The src attribute will be translated
into a -sourcepath switch, which is not recognized by JDK 1.1 ...

Stefan

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message