ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Does Ant's version 1.4.1 support Java's jdk1.1.8?
Date Thu, 31 Jan 2002 08:37:17 GMT
On Wed, 30 Jan 2002, Zhendi Su <rachael.su@oracle.com> wrote:

> for our development it's important that we use jdk 1.1 to compile
> all of our java files.

So use JDK 1.1 to run Ant, that's all.

> I looked at ant's source code and there seems to be no javac11.java
> provided (under taskdef.compilers/).  I only see javac12.java, and
> this is the class that caused crashing when running ant.

Javac12.java handles the compiler for both JDK 1.1 and 1.2, there are
several places in that code where command line switches will be
adapted to the version of the JVM that is currently running Ant.

For example, the depend attribute will be translated into -depend if
Ant is currently running on a 1.1 JVM and into -Xdepend on a 1.2
system.

Stefan

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message