ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chuck Stern <cst...@safenetconsulting.com>
Subject RE: Unexpected element "ftp"
Date Thu, 24 Jan 2002 11:34:46 GMT
Did you verify the FTP classes where in the optional.jar your using?  I ran
into this problem with FTP and I went through the mailing list trying
everything.  Turned out the class was missing and had to find a different
version that included it.  That's the first thing I check when I see this
error.  I'm pretty sure the current nightly build has it missing, I'm not
sure when in the process it would get added.

HTH,
Chuck

-----Original Message-----
From: Stephen Huey [mailto:stephenhuey@yahoo.com]
Sent: Wednesday, January 23, 2002 4:21 PM
To: ant-user@jakarta.apache.org
Subject: Unexpected element "ftp"


Okay, I've been trying to get Netcomponent's optional
ftp task to work,
and I went over to one of there mailing lists, but
someone was pretty
sure my problem was just an Ant config one.  He was a
Linux user, and threw
the simple ftp task tag block from my buildfile.xml
into some of his code,
and it successfully attempted to open a connection to
my server.  So, we've
established that I didn't make an error there.

However, I've posted on here lately, and I've tried
all the suggestions, but still nothing works.  I
successfully set ANT_HOME and JAVA_HOME and the PATH.
In fact, I've successfully compiled with Ant--I just
can't get the optional ftp task to work.

Basically, I downloaded NetComponents' stuff
(including the JAR file
necessary), and I've tried all sorts of different
things--like putting
the JAR file in my ant\lib directory, making sure that
that's in the
CLASSPATH, and yes, I also have the optional JAR that
you're supposed to download and stick into your
ant\lib directory (and it's in my classpath, too).
I've tried this in both WinME and Win2000, but to no
avail.  Is there anything I need in the buildfile
besides the following code:

<ftp server="jungle.owlnet.rice.edu"
       userid="sirstevo"
       password="****">
    <fileset dir="build"/>
  </ftp>

Do I need a loadlib or taskdef or something like that,
or SHOULD it be automatic?


It still generates an error.  Please help!  The last
part of the error message with -debug turned on looks
like this:



BUILD FAILED

C:\antfiles\buildfile.xml:20: Unexpected element "ftp"
        at
org.apache.tools.ant.ProjectHelper.parse(ProjectHelper.java:135)
        at
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.jav
a:85)
        at
org.apache.tools.ant.Main.runBuild(Main.java:439)
        at
org.apache.tools.ant.Main.start(Main.java:153)
        at
org.apache.tools.ant.Main.main(Main.java:176)

Total time: 0 seconds
C:\>



__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message