ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zhendi Su <rachael...@oracle.com>
Subject Re: Does Ant's version 1.4.1 support Java's jdk1.1.8?
Date Wed, 30 Jan 2002 18:22:50 GMT
Hi Stefan,

Thank you for your reply.  I have another question:  for our development it's
important that we use jdk 1.1 to compile all of our java files.  I looked at
ant's source code and there seems to be no javac11.java provided (under
taskdef.compilers/).  I only see javac12.java, and this is the class that
caused crashing when running ant.  So is there an equivalent javac11.java
provided for any version of ant?  Thanks a lot!

Zhendi

Stefan Bodewig wrote:

> On Tue, 29 Jan 2002, Zhendi Su <rachael.su@oracle.com> wrote:
>
> > I basically switched the compilers by typing:
> >
> > setenv JAVA_HOME  /local/java/jdk1.1.8, or
> > setenv JAVA_HOME  /local/java/jdk1.2.2
> >
>
> This should work (and you don't need to put classes.zip into the
> classpath property explicitly), but you have to make sure you are
> really running the correct version of java as well.  No matter what
> you set JAVA_HOME to, if you run the java executable of JDK 1.2, it
> will use the compiler of JDK 1.2, or at least try to.
>
> Stefan
>
> --
> To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message