ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jubin Gosar <Jubin.Go...@Netdecisions.com>
Subject RE: Can not get build.xml to work
Date Fri, 25 Jan 2002 07:15:46 GMT
How can we turn off the echo ( I know i't a simple question but I am new to
Ant )

Jubin

-----Original Message-----
From: Steve Loughran [mailto:steve_l@iseran.com]
Sent: Friday, January 25, 2002 12:01 PM
To: Ant Users List
Subject: Re: Can not get build.xml to work



----- Original Message -----
From: "Dave Murvin" <davem@drme.com>
To: "Ant Users List" <ant-user@jakarta.apache.org>
Sent: Thursday, January 24, 2002 6:12 PM
Subject: Re: Can not get build.xml to work


> At 09:19 AM 1/24/2002, you wrote:
> >there is probably an error in one of the env variables which is breaking
the
> >java call; it has nothing to do with the build file.
> >
> >turning off the echo is a good step; look at the java call to see if you
can
> >spot the problem
>
>
> It looks like the java call is having a problem with some version of the
> ant_home - see the last part of the -classpath.  Is this the problem?  I
am
> not sure what is happening here.  My environment variable is ANT_HOME and
> it seems to work correctly for the other Ant directories.  Where does the
> -Dant.home come from?
>
>
> C:\Program Files\UW Classes\Java Certificate 2001\Java
> Fundamentals\Assignments\Assignment01>"C:\java\jdk13\bin\java" -classpath
>
"C:\java\jdk13\lib\tools.jar;C:\Ant\jakarta-ant-1.4.1\lib\jaxp.jar;C:\Ant\ja
karta-ant-1.4.1\lib\crimson.jar;C:\Ant\jakarta-ant-1.4.1\lib\ant.jar;.;C:\WD
T400\JAVA;C:\WDT400\Studio35\lib\swingall.jar;C:\WDT400\Studio35\lib\wdt400u
t.jar;G:\"
> -Dant.home="C:\Ant\jakarta-ant-1.4.1"  org.apache.tools.ant.Main compile
> Usage: java [-options] class [args...]
>             (to execute a class)
>     or  java -jar [-options] jarfile
>

Nothing jumps out except for the quotes around here

-Dant.home="C:\Ant\jakarta-ant-1.4.1"

1. can you list the env variables from a 'SET' command

2. try clearing classpath,
SET CLASSPATH=
before a run and see if that changest things.




--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message