ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diane Holt <hol...@yahoo.com>
Subject Re: ant & junit works on win98, fails on deadrat 6.2
Date Tue, 29 Jan 2002 15:39:54 GMT
--- Ray Tayek <rtayek@mediaone.net> wrote:
> iirc, error does not mean that the test failed. some thing else is wrong
> i  think. if you can, run it with -debug and see what it says.

Oh, I fully expected the test to error-out, since I don't have your test
:)

I included that snippet to show you that the <junit> task in fact worked
for me.

> >So I'd suggest putting junit.jar in $ANT_HOME/lib again, then going
> >from there to try and narrow it down to what's getting in the way.
> 
> i did and it says the same thing :(

Could you extract org/apache/tools/ant/taskdefs/defaults.properties from
your $ANT_HOME/lib/ant.jar file and do a 'grep junit' on it to make sure
the task definition is in there? Also, you might want to run a table of
contents on your junit.jar to make sure the jar-file is good. And maybe
your optional.jar file as well, to make sure the .../junit/* classes are
there.

Diane

=====
(holtdl@yahoo.com)



__________________________________________________
Do You Yahoo!?
Great stuff seeking new owners in Yahoo! Auctions! 
http://auctions.yahoo.com

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message