ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin van Wieringen <mwier...@spd.estec.esa.nl>
Subject RE: W2000 SP1 Delete task does nothing
Date Mon, 21 Jan 2002 10:27:24 GMT
Hi,

>probably you have a window open onto that directory; the OS says the dir 
is
>in use and wont kill it. Same as if you try and delete the dir from a
>different window

That is not possible as the directory I am trying to delete is created by 
Ant itself (if it is not there yet) when I build my app. I each time delete 
the build directory myself without any problems.  So each time ant 
recreates the build directory. Compiles my class and puts it in the build 
directory then when I call

  <target name="clean">
    <!-- Delete the ${build} and ${dist} directory trees -->
    <delete dir="${build}"/>
    <delete dir="${dist}"/>
  </target>

The build directory is not cleared from the class meaning the <target 
name="clean"> does nothing. I am thinking more of a bug in Ant as it does 
not display any errormessage if the <target name="clean"> failed. 
Developers any ideas?

Greetings,

Martin van Wieringen


> -----Original Message-----
> From: Steve Loughran [mailto:steve_l@iseran.com]
> Sent: Friday, January 18, 2002 8:54 PM
> To: Ant Users List; mwiering@spd.estec.esa.nl
> Hello,
>
> I am using w2000 SP1. I have a simple build file compiling one class. The
> build is successfull however the build directory is not cleared from the
> one file. I do not get any errormessage that deleting is not allowed? It
> can create the build directory so I do not see why deleting the files in
> it
> should fail. Any ideas?


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message