ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Esbrook, Scott" <Scott_Esbr...@compuware.com>
Subject unexplained BUILD FAILED
Date Tue, 11 Dec 2001 21:49:10 GMT
Hello,

I'm using Ant 1.4.1 on W2K Pro and am getting an unexplained BUILD FAILED
when executing the Sourcesafe vssget task. Compared to the output from the
command line, the Ant output looks fine, and files are retrieved as would be
expected. But at the end it says BUILD FAILED and exits immediately instead
of performing the other necessary tasks.

//////////////////////////////////////
Output:

D:\data\ovjava\POC\ov>ant ssf -verbose
Ant version 1.4.1 compiled on October 11 2001
Buildfile: build.xml
Detected Java version: 1.3 in: d:\jdk1.3\jre
Detected OS: Windows 2000
parsing buildfile D:\data\ovjava\POC\ov\build.xml with URI =
file:D:/data/ovjava
/POC/ov/build.xml
Project base dir set to: D:\data\ovjava\POC\ov
 [property] Loading D:\data\ovjava\POC\ov\build\user.properties
Build sequence for target `ssf' is [ssf]
Complete build sequence is [ssf, init, compile, appjar, regen, stop_tomcat,
test
, clean, start_tomcat, build, dist, deltc, devbuild, deploywar]

ssf:
   [vssget] $/POC:
   [vssget]

<SNIP>

   [vssget] Yahoo.xml
   [vssget]

BUILD FAILED

D:\data\ovjava\POC\ov\build.xml:202: Failed executing:
C:\Progra~1\Micros~4\Comm
on\VSS\win32\ss Get $/POC -I- -R
        at
org.apache.tools.ant.taskdefs.optional.vss.MSVSSGET.execute(MSVSSGET.
java:185)
        at org.apache.tools.ant.Task.perform(Task.java:217)
        at org.apache.tools.ant.Target.execute(Target.java:184)
        at org.apache.tools.ant.Target.performTasks(Target.java:202)
        at org.apache.tools.ant.Project.executeTarget(Project.java:601)
        at org.apache.tools.ant.Project.executeTargets(Project.java:560)
        at org.apache.tools.ant.Main.runBuild(Main.java:454)
        at org.apache.tools.ant.Main.start(Main.java:153)
        at org.apache.tools.ant.Main.main(Main.java:176)

//////////////////////////////////////
build.xml target xml:

   <target name="ssf">
        <vssget vsspath="/POC"
            recursive="true" 
            serverPath="\\fhnetapp1\webtech\POC"
            ssdir="C:/Progra~1/Micros~4/Common/VSS/win32"
            writable="false"/>
   </target>

//////////////////////////////////////

Note that the output where [vssget] messages appear are nearly identical to
the output when executing 'ss Get $/POC -I- -R' from the commandline (Ant
adds the '   [vssget]'), but from the commandline SourceSafe does not error
or complain whatsoever.

Any ideas why this is failing?

Scott Esbrook
Software Developer
Compuware Corporation
248 737 7300 x12978 

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message