ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Les Hughes <leslie.hug...@rubus.com>
Subject RE: Ant Perforce Tasks
Date Mon, 03 Dec 2001 18:11:09 GMT
 
Hi Stuart,

Can you supply a snippet of your buildfile? On my test box with

<p4change/>
<echo message="Change is ${p4.change}"/>

and


ant -verbose

I get

....
[p4change] Execing p4 change -o
[p4change] Execing p4 change -i
[p4change] Change Number is 108
[echo] Change is 108

and in p4win

Change   108 {Autosubmit by Ant}

So I can't reproduce your bug. This code has been stable for ages so can you
also make sure that you have a late version of Ant (>1.4).

Also, run it in -verbose or -debug modes and paste relevant results. And
which version of p4 are you using? I've tested with 99.2 and 2000.2 - but
not the later 2001 releases.


Bye,

Les

P.S. Feel free to mail me direct but can you cc ant-user that way the
solutions get into the archive.





-----Original Message-----
From: Barker, Stuart
To: 'leslie.hughes@rubus.com'; 'kirk@radik.com'
Sent: 03/12/01 17:29
Subject: Ant Perforce Tasks

Gents,

I'm currently migrating our build process to use Ant, along with
Perforce.
However, I've found that the p4change task sets the p4.change property
incorrectly. It amends a 1 to the changelist number, so what appears as
CL344 in the perforce client, appears as CL3441 in Ant. Are you aware of
this, and if so, is there a fix available?

Cheers,

Stuart

Stuart Barker
Senior Java Developer
B&Q Direct Channels
Tel:	+44 (0)23 8062 1915
Web:	http://www.diy.com

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message