ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kazandjian Erik <Erik.Kazandj...@siemens.atea.be>
Subject RE: upgrade from 1.3 to 1.4.1
Date Wed, 14 Nov 2001 10:31:30 GMT
If I put these 2 jars (jaxp.jar and crimson.jar) in my classpath shoudn't
that do the job ?

Erik

-----Original Message-----
From: Stephane Bailliez [mailto:sbailliez@imediation.com]
Sent: woensdag 14 november 2001 11:24
To: Ant Users List
Subject: RE: upgrade from 1.3 to 1.4.1


> -----Original Message-----
> From: Kazandjian Erik [mailto:Erik.Kazandjian@siemens.atea.be]

> This is what I did. 
> 
> I untarred the tar.gz file containing the binaries for ant1.4.1
> I added the file optional.jar to $ANT_HOME/lib
> 
> When I then run ant I get
> 
> No JAXP compliant XML parser found. Please visit 
> http://xml.apache.org for a
> suitable parser

This is not normal.
There is crimson.jar and jaxp.jar along with ant.jar in lib directory.
crimson is the DOML2/SAX2 parser, jaxp is the jaxp 1.1 interfaces.

> So I took the old jaxp.jar file from my Ant1.3 and then the 
> problems started

Not a good idea since jaxp.jar in Ant 1.3 is JAXP 1.0 that was with
parser.jar which was DOML1
Use the one shipped with Ant 1.4.x unless you know perfectly what you are
doing.
Plus crimson and jaxp are bugfix releases for JAXP 1.1 release.

Stephane.

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message