ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Pearlman Spencer" <Alan.PearlmanSpen...@Mobileaware.com>
Subject RE: Problem with classes still loaded from previous... (was: Problem with classes still loaded from WLS...)
Date Wed, 28 Nov 2001 14:41:53 GMT
More follow on:
I still have the problem.
I run a build from cruise control: all OK.
I run the second build and I can't delete the jar files produced by the
first build
because, I presume, something in the first build is still holding on. I
thought it was
WLS, I removed it and it still happened. I thought it was junit, I
removed it and it
was still happening. Now I think it may be the javadoc.
I'm tempted to replace my <ant> call with a <java fork="true"> seems
overkill though.
Other people must (?) have seen this problem.

If I try to delete the file by hand it (windows) will not let me until
I stop the cruise control process.

I presume the same problem would occur if I tried to delete the files at
the end
of the ant script running.

Any ideas?

Thanks,
Alan.

-----Original Message-----
From: Alan Pearlman Spencer 
Sent: 28 November 2001 10:18
To: Ant Users List
Subject: RE: Problem with classes still loaded from WLS...


Follow on:
I've removed the weblogic and it is still there.
If I remove the unit testing it goes away.
I now have junit running with a fork="true" and it seems to be OK.
But I can't get WLS to run in a separate VM using the <wlrun>
task, I could just do a java to get it to run, but it seems to defeat
the
purpose.
Is it possible to have an <ant> call run in a seperate VM?
Maybe it would be nice to have a <fork> task that forked to run
the tasks within???
Thanks,
Alan.

-----Original Message-----
From: Alan Pearlman Spencer 
Sent: 28 November 2001 09:28
To: Ant Users List
Subject: Problem with classes still loaded from WLS...


Hi All,
I have an anoying.interesting problem.
I have a build script that runs from CruiseControl.
It builds everything, runs unit tests, starts weblogic, runs system
tests and then finishes.
But, the next time it runs it tries to remove the previous build, but it
says it can't delete the
.jar files.
I presume that this is because weblogic loaded the jar files and is not
letting go even though it has been
shut down (as it runs in the same VM as the build).
I would like to have the <wlrun> task run in a separate VM, but I can't
seem to get it to do this...
Any idea

Thanks,
Alan.
		Alan Pearlman-Spencer
		MobileAware Ltd.
		3225 Lake Drive, 
		National Digital Park, 
		CityWest Business Campus, 
		Dublin 24. 
		Ireland. 
		Phone: +353 (0)1 2410 500 
		Fax: +353 (0)1 2410 501 



--
To unsubscribe, e-mail:
<mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:ant-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:
<mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message