ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "McVeigh, Ryan" <>
Subject RE: ejbjar with jikes deploy problems
Date Mon, 19 Nov 2001 21:08:15 GMT
I don't have any problem using jikes for my ejbjar task at all.  This is WL
6.0 SP2 and Jikes 1.15.


-----Original Message-----
From: Paul Cody Johnston []
Sent: Monday, November 19, 2001 3:04 PM
To: Ant Users List
Subject: Re: ejbjar with jikes deploy problems

On Monday 19 November 2001 12:43 pm, you wrote:
> Greetings,
> Just curious to know if anyone else has had problems deploying to Weblogic
> when using jikes as their compiler.  <ejbjar> works fine, but deploying
> jars, I get a
> The WebLogic Server did not start up properly.
> Exception raised: java.lang.reflect.InvocationTargetException
> java.lang.reflect.InvocationTargetException: java.lang.VerifyError:
> pkg/class, method: method signature: ()V) Expecting to find integer on
> stack at java.lang.Class.newInstance0(Native Method)
> error.  If I change my build.compiler property to "modern", the ejbs
> fine, but it takes 50 mins vs 12 minutes with jikes.
> anybody else had this problem?

Not with weblogic, but I have seen Verification errors with jikes-generated 
classfiles (though not in a long time).  Check your version of jikes and 
upgrade if possible. 


To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message