ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephane Bailliez <sbaill...@imediation.com>
Subject RE: Junit Report Problems
Date Wed, 28 Nov 2001 17:22:27 GMT
> -----Original Message-----
> From: Mike Downes [mailto:mdownes@accelrys.com]
> Hi Stephane

> Thanks for you input on this, but can I clarify that 
> xalan-j_2_2_D10 which
> has xalanj1compat.jar and xalan-j_2_2_D13 which does not have the
> xalanj1compat.jar should no longer be used.

> Also are they not both xalan 2?

Yes they are but as stated they are developpement version that is: not
stable.
The Xalan team will not ship anymore Xalan compatibility API for Xalan 1
with Xalan2.

If you require the Xalan 1 API you'd better migrate to JAXP if possible or
to the Xalan 2 API.

Small note: If you have a code that use the Xalan1 API and that was compiled
with Xalan1 chance is that it will not work with the Xalan1 compatibility
jar. You must compile with the compatibility jar otherwise you will get the
error you have.
Unless we did a mistake, optional.jar was compiled with the Xalan1
compatibility jar.


The current code in JUnit report looks first for Xalan2 then Xalan1. JUnit
report "needs" Xalan because it makes use in the stylesheet of a
xalan-specific redirect extension.

Stephane

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message