ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@apache.org>
Subject Re: Problem with patternsets in ANT 1.4.1
Date Wed, 28 Nov 2001 07:44:53 GMT
On Wed, 28 Nov 2001 04:25, Andrew Spyker wrote:
> All,
>
> I just moved my build from 1.3 to 1.4.1.  I am now seeing the following
> issue:
>
> If I have patternsets defined in the build.xml under build targets such
> as:
>
> <copy todir="${dest.dir}">
>   <fileset dir="${src.dir}">
>     <patternset id="myproperties">
>       <include name="**/*.properties"/>
>     </patternset>
>    </fileset>
> </copy>
>
> I get the following error when the target runs:
>
> "Overriding previous definition of reference to myproperties"
>
> I don't have a patternset defined anywhere else in the same build.xml
> with the same id, so I don't think I am redefining it.  I looked at the
> ANT source and this didn't seem to make sense until I ran -debug.  From
> the looks of it, the parser(??) goes through the file once before any
> target it run an it calls addReference which then causes the second
> addReference (when it actually does the target) to be log annoying.
>
> I have temporarily worked around the problem by taking away the id=""
> part, but I was wondering if this indicates an introduced bug as this
> didn't happen with 1.3.
>
> I searched bugzilla but didn't see anything.  Can someone confirm this
> and them I'll open up a bug?

While I haven't tried it I expect it would break. It is one of a few known 
issues with regards to interpreting the object model. You should prably still 
chuck it in bugzilla though.

-- 
Cheers,

Pete

------------------------------------------
I just hate 'yes' men, don't you Smithers?
------------------------------------------

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message