ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@apache.org>
Subject Re: Ant 1.4.1 and JUnit
Date Mon, 26 Nov 2001 23:43:58 GMT
On Tue, 27 Nov 2001 10:42, Steve Cohen wrote:
> Duh!  That was it.  Thank you.  I had them there in an earlier attempt
> but forgot to put them back for the later one.

np ;)

>
> -----Original Message-----
> From: Peter Donald [mailto:peter@apache.org]
> Sent: Monday, November 26, 2001 5:35 PM
> To: Ant Users List
> Subject: Re: Ant 1.4.1 and JUnit
>
>
> Is junit.jar in ant/lib ?
>
> On Tue, 27 Nov 2001 10:35, Steve Cohen wrote:
> > OK, yes, thanks, I hadn't done that.  However, now that I have done
> > that, and confirm that the junit ant task .class files are in
> > optional.jar, I STILL get the error when trying to run a <junit> task.
> >
> > -----Original Message-----
> > From: Peter Donald [mailto:peter@apache.org]
> > Sent: Monday, November 26, 2001 4:24 PM
> > To: Ant Users List
> > Subject: Re: Ant 1.4.1 and JUnit
> >
> >
> > When building optional.jar you need to include junit.jar in classpath
>
> -
>
> > best
> > to do that by placing itt in lib/optional/junit.jar IIRC.
> >
> > On Tue, 27 Nov 2001 08:38, Steve Cohen wrote:
> > > I built an optional.jar as part of the ant build process.  Now that
>
> I
>
> > > look at it, I don't see anything in that jar with "junit" in its
>
> name
>
> > > except junit-frames.xsl and junit-noframes.xsl.  Have I overlooked
> > > something?  Which class should be holding the junit task in
> > > optional.jar?
> > >
> > >
> > > -----Original Message-----
> > > From: Erik Hatcher [mailto:jakarta-ant@ehatchersolutions.com]
> > > Sent: Monday, November 26, 2001 3:20 PM
> > > To: Ant Users List
> > > Subject: Re: Ant 1.4.1 and JUnit
> > >
> > >
> > > Did you get the optional JAR file also?  It contains the <junit>
>
> task
>
> > > itself.
> > >
> > >
> > > ----- Original Message -----
> > > From: "Steve Cohen" <SteveC@ignitesports.com>
> > > To: <ant-user@jakarta.apache.org>
> > > Sent: Monday, November 26, 2001 4:17 PM
> > > Subject: Ant 1.4.1 and JUnit
> > >
> > >
> > > I am attempting to upgrade from Ant 1.3 to 1.4.1.  Build.xmls with
> >
> > junit
> >
> > > tasks are failing with this message:
> > >
> > > "Could not create task of type: junit. Common solutions are to use
> > > taskdef to declare your task, or, if this is an optional task, to
>
> put
>
> > > the optional.jar in the lib directory of your ant installation
> > > (ANT_HOME)."
> > >
> > > According to the docs, in order to use the <junit> task, I must put
> > > junit.jar in the lib of my ANT_HOME dir.  But it IS there.  What
>
> else
>
> > is
> >
> > > needed to run <junit> tasks?  Or is this error message spurious and
> > > something else wrong?
> > >
> > > -----------------------------------------------------------------
> > > Steve Cohen
> > > Sr. Software Engineer
> > > Ignite Sports Media
> > > 4410 N. Ravenswood
> > > Chicago IL 60640
> > > (773)-293-4342
> > > stevec@ignitesports.com

-- 
Cheers,

Pete

When a stupid man is doing something he's ashamed of, he always 
declares that it is his duty.
					 George Bernard Shaw 

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message