ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Devan Iyer <Devan.I...@crystaldecisions.com>
Subject RE: Newbie question
Date Tue, 13 Nov 2001 21:37:52 GMT
Try:

<property environment="chooseAnyName" />

<property name="myProperty" value="${chooseAnyName.THE_DOS_ENV_NAME}" />

eg:
<property environment="myBuildEnv" />

<property name="my_build_dest" value="${chooseAnyName.BUILD_DEST}" />

where at the cmd line I had "set BUILD_DEST=c:\mybuilddest".

Hope this helps.

-----Original Message-----
From: Kumar L [mailto:kumarl@tibco.com]
Sent: Tuesday, November 13, 2001 1:28 PM
To: ant-user@jakarta.apache.org
Subject: Newbie question


Hi
I am new new to using ant. I am using the 1.4.1 version of it.
I want to know if there is a way of importing the system variables in to
the build.xml.

I have a plenty of environment variables which i want to use in my build
process.
like:
${PORT} = sol26xx2
${path_for_tools} = /root/tools/${PORT}

how should I access these variables from my build.xml?
I could not get much info on this from the manuals (might be i am
looking at the wrong place)

Can someone pls help me ?
Thanks in advance.
Kumar


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message