ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ron Coutts" <R...@quadrus.com>
Subject Problem with Visual SourceSafe task
Date Tue, 27 Nov 2001 21:02:06 GMT
The VSS task does not seem to work properly.  I'm getting the error 'No
VSS database (srcsafe.ini) found.  Use the SSDIR environment variable or
run netsetup'.  Currently I'm using the VSS command line interface from
Perl scripts to do gets, and in those scripts the SSDIR environment
variable must be set.  For some reason, the VSS task is not setting this
environment variable.  What am I doing wrong?

Also, there seems to be an inconsistency between the VSS task, and VSS
itself.  In my working scripts, I set 'SSDIR=\\private1\midas$', i.e. to
the directory where the srcsafe.ini file is located.  However in the VSS
task, the ssdir attribute is supposed to refer to the directory where
the ss.exe file is located.  Is this correct, or a documentation typo?

Thanks in advance for any help provided.

Ron


P.S. 
Here's the build file I'm using:

<project name="VssTest" default="get">
	<target name="get">
		<vssget localPath="d:\delme"
		        recursive="false"
			  login="userid,password"
			  vsspath="/MidasWksp"
			  writable="false" 
			  ssdir="C:\Program Files\Microsoft Visual
Studio\Common\VSS\win32"
			  serverPath="\\private1\midas$"
			  />
	</target>

</project>

And here's the Ant output:

Buildfile: build2.xml

get:
   [vssget] No VSS database (srcsafe.ini) found.  Use the SSDIR
environment variable or run netsetup.

BUILD FAILED

D:\midasroot\Developers\RonC\AntTests\VssTest\build2.xml:11: Failed
executing: "C:\Program Files\Microsoft Visual Studio\Common\VSS\win32\ss
" Get $/MidasWksp -GLD:\delme -I- -YAutoUser,adrs

Total time: 1 second



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message