ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefano Mancarella" <mancare...@opoipi.bancaintesa.it>
Subject Re: JUnit problems
Date Fri, 16 Nov 2001 17:08:28 GMT
Unfortunately it does.
Any other idea?

----- Original Message ----- 
From: "Christopher Berry" <christopher.berry@etrade.com>
To: "'Ant Users List'" <ant-user@jakarta.apache.org>
Sent: Friday, November 16, 2001 18:47
Subject: RE: JUnit problems


> If you run Ant with -quiet, then I don't think the output will appear...
> 
>  -----Original Message-----
>  From: Stefano Mancarella [mailto:mancarella@opoipi.bancaintesa.it]
>  Sent: Friday, November 16, 2001 10:11 AM
>  To: ant-user@jakarta.apache.org
>  Subject: JUnit problems
> 
> 
>  I've some problems using the JUnit task.
>  I have some tests which load a resource from the classpath using
>  getSystemResource().
>  This only works if I use fork=yes in my JUnit task, otherwise
>  the resource
>  is not found (due to classloader issues, I suppose).
>  Using fork=yes two other problems arise:
>  1) The tests run much slower (I can live with this)
>  2) All test output is sent to standard out/err, even if i don't specify
>  "withOutAndErr" (I can't live with this).
> 
>  Is it possible to have test output "swallowed" by the
>  formatters, even if I use fork=yes ?



--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message