ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jill Stephenson" <jill.stephen...@suncorpmetway.com.au>
Subject Re: Starting JBoss from a build file
Date Thu, 29 Nov 2001 23:03:13 GMT
Oops, found the problem.  A typo in the class name of one of the jvmargs !!

--
Jill

----- Original Message -----
From: "Jill Stephenson" <jill.stephenson@suncorpmetway.com.au>
To: "Ant Users List" <ant-user@jakarta.apache.org>
Sent: Thursday, November 29, 2001 4:46 PM
Subject: Starting JBoss from a build file


> I am trying to startup JBoss from within a target for running tests.
> I (think!) that I have all the relevant pieces as taken from the JBoss
> scripts run_with_tomcat.bat and run.bat.  The following is the
> relevant snippet from my build file, where jboss.home is a property
> set to my jboss installation directory.
>
>       <java classname="org.jboss.Main"
>
>
classpath=";${java.home}/../lib/tools.jar;${jboss.home}/jboss/bin/run.jar;${
> jboss.home}/jboss/lib/crimson.jar"
>             fork="yes"
>             dir="${jboss.home}/jboss/bin">
>         <jvmarg
>
value="-Djavax.xml.parsers.DocumentBuilderFactory=org.apache.crimson.jaxp.Do
> cumentBuilderFactoryImp" />
>         <jvmarg
>
value="-Djavax.xml.parsers.SAXParserFactory=org.apache.crimson.jaxp.SAXParse
> rFactoryImpl" />
>         <arg value="tomcat" />
>       </java>
>
> Everything starts off OK but it doesn't seem to be able to find the
> crimson classes as per the following output
>
>      [java] Forking
>
c:\java\jdk1.3.1_01\jre\..\bin\java.exe -Djavax.xml.parsers.DocumentBuilderF
>
actory=org.apache.crimson.jaxp.DocumentBuilderFactoryImp -Djavax.xml.parsers
> .SAXParserFactory=org.apache.crimson.jaxp.SAXParserFactoryImpl -classpath
>
C:\java\jdk1.3.1_01\lib\tools.jar;C:\java\JBoss-2.4.3_Tomcat-3.2.3\jboss\bin
> \run.jar;C:\java\JBoss-2.4.3_Tomcat-3.2.3\jboss\lib\crimson.jar
> org.jboss.Main tomcat
>      [java] jboss.home = C:\java\JBoss-2.4.3_Tomcat-3.2.3\jboss
>      [java] Using JAAS LoginConfig:
> file:/C:/java/JBoss-2.4.3_Tomcat-3.2.3/jboss/conf/tomcat/auth.conf
>      [java] Using configuration "tomcat"
>      [java] [root] Started Log4jService,
>
config=file:/C:/java/JBoss-2.4.3_Tomcat-3.2.3/jboss/conf/tomcat/log4j.proper
> ties
>      [java] [Info] Java version: 1.3.1_01,Sun Microsystems Inc.
>      [java] [Info] Java VM: Java HotSpot(TM) Client VM 1.3.1_01,Sun
> Microsystems Inc.
>      [java] [Info] System: Windows 2000 5.0,x86
>      [java] [Shutdown] Shutdown hook added
>      [java] [Default] Runtime error
>      [java] [Default] javax.xml.parsers.FactoryConfigurationError:
> java.lang.ClassNotFoundException:
> org.apache.crimson.jaxp.DocumentBuilderFactoryImp
>      [java] [Default]   at
>
javax.xml.parsers.DocumentBuilderFactory.newInstance(DocumentBuilderFactory.
> java:118)
>      [java] [Default]
>      [java] [Default]   at
>
org.jboss.configuration.ConfigurationService.loadConfiguration(Configuration
> Service.java:371)
>      [java] [Default]
>      [java] [Default]   at java.lang.reflect.Method.invoke(Native Method)
>      [java] [Default]
>      [java] [Default]   at
> com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1628)
>      [java] [Default]
>      [java] [Default]   at
> com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1523)
>      [java] [Default]
>      [java] [Default]   at org.jboss.Main.<init>(Main.java:213)
>      [java] [Default]
>      [java] [Default]   at org.jboss.Main$1.run(Main.java:127)
>      [java] [Default] JBoss 2.4.3 Started in 0m:0s
>
> The same Java command works from the command line as does the following
> ant task once I remove the pause from run.bat.  However, I'd prefer not to
> run a platform specific command file.
>
>       <exec executable="${jboss.home}/jboss/bin/run_with_tomcat.bat"
>             dir="${jboss.home}/jboss/bin" />
>
> Has anyone had any success with this?  Or I am missing something obvious?
>
> --
> Jill



-----------------------------------------------------------------------------------

The contents of this message are the views of the Author and do not necessarily reflect the
views of SUNCORP METWAY LTD  ABN 66 010 831 722. 

The content of this e-mail, including attachments is a confidential communication between
the Suncorp Metway Group and the intended addressee. Any unauthorised use of the contents
is expressly prohibited. If you have received this e-mail in error please contact the sender
immediately and then delete the message and any attachment(s).

http://www.suncorpmetway.com.au


--
To unsubscribe, e-mail:   <mailto:ant-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-user-help@jakarta.apache.org>


Mime
View raw message