ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Juergen Damke" <DA...@de.ibm.com>
Subject whats different in the java task in Ant 1.4 ?
Date Thu, 04 Oct 2001 14:07:08 GMT

I have a problem with the <java /> task in Ant 1.4 which did not
occur with Ant 1.3.
The system is AIX 4.3.3 with JDK 1.2.2 any PTF.

      <java classname="com.installshield.isje.ISJE" fork="yes" failonerror
="yes">
          <arg path="${temp-xml}"/>
          <arg value="-build"/>
          <classpath refid="ishield.classpath"/>
      </java>

With Ant 1.3 the class is execute fine, with Ant 1.4 however I get an
recursive error:

     [java] Error: Wrong version of
/usr/java_dev2_ptf7/jre/sh/../../bin/../bin/java for this version of AIX.
     [java] Error: Wrong version of
/usr/java_dev2_ptf7/jre/sh/../../bin/../bin/../bin/java for this version of
AIX.
     [java] Error: Wrong version of
/usr/java_dev2_ptf7/jre/sh/../../bin/../bin/../bin/../bin/java for this
version of AIX.
     [java] Error: Wrong version of
/usr/java_dev2_ptf7/jre/sh/../../bin/../bin/../bin/../bin/../bin/java for
this version of AIX.

JDK, build.xml etc. is always the same, just different Ant version.

any ideas ?

Mit freundlichen Grüßen / With best regards
Jürgen Damke
______________________________________________________________________
IBM EL ADS PvC Solutions 2, Dept 6547
URL: http://www-4.ibm.com/software/webservers/portal/
IBM Development Laboratory Böblingen, Germany
Phone: +49/7031/16 -3375, Fax: -4888  -  MailTo:damke@de.ibm.com


Mime
View raw message