ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Art Blake" <art.bl...@mindspring.com>
Subject RE: start tomcat in ant
Date Tue, 09 Oct 2001 00:18:22 GMT
I asked a similar question a few days ago, but didn't get any responses.  I
am not getting an IOException however.

These three methods of starting tomcat work for me, but every single one
causes ant to block while tomcat is running.  I am trying to get ant to
start tomcat, and continue running.

    <!-- set environment variables to properties prefixed to env -->
    <property environment="env"/>

    <!--1 -->

    <exec dir="${env.TOMCAT_HOME}/bin" executable="startup.bat"
vmlauncher="false"/>


    <!--2 -->

    <exec dir="${env.TOMCAT_HOME}/bin" executable="cmd.exe">
      <arg line="/c startup.bat"/>
    </exec>

    <!--3 -->

    <exec dir="${env.TOMCAT_HOME}/bin" executable="cmd.exe">
      <arg line="/c start startup.bat"/>
    </exec>


good luck

-----Original Message-----
From: Guan, Kelly [mailto:C_Kelly.Guan@wingcast.com]
Sent: Monday, October 08, 2001 7:10 PM
To: ant-user@jakarta.apache.org
Subject: start tomcat in ant


sorry if anyone get this email twice.

I am trying to start tomcat in ant, and I am using :
<exec dir="c:/tomcat/bin" executable="startup" os="Windows 2000"
failonerror="true" />

I get IOException thrown by JVM.

Anyone can give me some idea how to get over this problem?

Really appreciated.

Thanks


Mime
View raw message