ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ylan Segal" <y...@digiworks.tv>
Subject RE: Problem with the Copy-Task when used for non text files
Date Thu, 25 Oct 2001 22:08:15 GMT
I remember reading about a problem with filters when copying binary files in
this list I don't use it myself, so I am not 100% sure).

Try copying the file without any filters and see if it works. I know I copy
binary files all the time with ant and I have not had any problems.

Ylan Segal

-- Failure is not an option, it comes bundled with your Micro$oft product


-----Original Message-----
From: Weinmann, Alexander
[mailto:Alexander.Weinmann@mummert.polizei.niedersachsen.de]
Sent: Thursday, October 25, 2001 2:44 AM
To: 'ant-user@jakarta.apache.org'
Subject: AW: Problem with the Copy-Task when used for non text files




Below  is my copy task!
It copies some BEA weblogic certificate files from one
dir to another (Which might be something one should not do, I admit -
so don't tell anybody)
Anyway, it took me quite some time to track the problem down.
I did binary comparisons on all the copied files  and found out
that ONLY SOMETIMES when I run the task, I get binary differences
in the file "SerializedSystemIni.dat"
I do not know at the moment what circumstances make the task
behave differently.
As I am not sure about my testing environment at the moment,
I would not recommend you to spend much time on that.


====================
  <!-- Installation der applikation -->
  <target name="application" depends="init" if="bea-home">
     <mkdir dir="${bea-home}/${wls}/config/mikado/applications"/>
     <mkdir dir="${bea-home}/${wls}/config/mikado/logs/"/>
    <copy  todir="${bea-home}/${wls}/config/mikado" >
      <fileset dir="${bea-home}/${wls}/config/mydomain"

includes="*.crt,*.pem,SerializedSystemIni.dat,fileRealm.properties"/>
               <!--includes="fileRealm.properties"/-->
    </copy >
     <filter token="java.home" value="${java.home}"/>
     <filter token="bea-home" value="${bea-home}"/>
     <filter token="wls" value="${wls}"/>
    <copy  todir="${bea-home}/${wls}/config/mikado" filtering="true">
      <fileset dir="data/config/mikado"
includes="config.xml,startWebLogic.cmd"/>
    </copy >
  </target>


> -----Urspr√ľngliche Nachricht-----
> Von: Conor MacNeill [mailto:conor@cortexebusiness.com.au]
> Gesendet: Mittwoch, 24. Oktober 2001 15:43
> An: ant-user@jakarta.apache.org
> Betreff: Re: Problem with the Copy-Task when used for non text files
>
>
> Weinmann, Alexander wrote:
>
> > Hello ANT-Users,
> > Under windows 2000 I experienced several times that the
> > copy task did not work as expected. License files and other
> > "proprietary" formats seemed to have changed [when read
> > from other applications] after being copied.
> > Doing the Copy manually on the operating system level
> solved the problem
> > and made me think their might be a problem with the Copy-Task ..
> >
> > Any hints from the experts?
> >
> > P.S.: "Filtering" is off!
>
> That is what the last guy said - just kidding:-) The next time you
> encounter this, would you be able to investigate the nature of the
> differences, perhaps even resorting to a binary level diff.?
> Also if you
> could give us the <copy> snippet. Finally there may be other
> "line-oriented" processes being run over the files. This
> could be other
> Ant tasks such as <fixcrlf> being applied  to more files that
> it should
> or something like that.
>
> Any info would help to track down any issues.
>
> Thanks
> Conor
>


Mime
View raw message