ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter.FL...@syntegra.com
Subject Hanging ANT...
Date Thu, 11 Oct 2001 09:10:06 GMT
Hi,

I'm getting some strange behaviour from my build and I don't know whether
its ANT or the O/S, but I'll explain it anyway...

I currently use ANT 1.4, with NetComponents and Ant 1.4 Optional to automate
the build process for my project.  I am running this on 
a 600Mhz Pentium III with 256Mb or RAM, 512Mb of swap and all this running
Windows 2000 Professional Service Pack 2.

I have the following Java version:
java version "1.3.0_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0_01)
Java HotSpot(TM) Client VM (build 1.3.0_01, mixed mode)

My problem is that when I run ANT, if I move focus off the window and move
onto something else, the build process just stops in-between tasks and won't
resume until I reselect the window and press ENTER. 

I have a feeling its something in ANT, as the build time increases to the
length of time it hangs.  (If it was the command shell, I'd expect ANT to
have a short
build time but hang in the command shell).  As ANT's build time grows, I can
only assume that a thread in the JVM is going astray somewhere when ANT is
running.

Has anyone else experienced this?   Is there a workaround?

Best regards,
Peter




********************************************************************

This email may contain information which is privileged or confidential. If you are not the
intended recipient of this email, please notify the sender immediately and delete it without
reading, copying, storing, forwarding or disclosing its contents to any other person
Thank you

Check us out at http://www.syntegra.com

********************************************************************

Mime
View raw message