ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barry Jia <b...@brightspark.com>
Subject RE: How to Run Auto Build
Date Thu, 04 Oct 2001 15:56:57 GMT
Hi, 
I create a build.xml and a batch file, call auto.bat, which set up classpath
and call ant to run my build file.
 
in NT4, I use command : "at 00:00 /every:M,T,W,Th,F auto",  for test
purpose, I simple use "at 10:00 auto" (suppose current machine time is
9:58), when machine reach 10:00, this job invoke(as I found it disppear in
my scheduled job queue). In my build file, I delete a directory, checkout
source from SourceSafe and compile, etc.
The job invoked, but  I can not check it running or not, anyway I found the
directory which is hope to be deleted is still there, nothing happen.
I even put a option /interactive in the at command line, it looks the job
runs at background, I can not catch the output of the build.
I do not know how to do that.
Thanks

-----Original Message-----
From: Vittoria, Felice [mailto:Felice_Vittoria@bmc.com]
Sent: Thursday, October 04, 2001 11:46 AM
To: 'bjia@brightspark.com'
Subject: RE: How to Run Auto Build


Barry,
 
Can you tell me what command you are typing and/or what schedule tool you
are using?  
 
Thanks,
Felice

-----Original Message-----
From: Barry Jia [mailto:bjia@brightspark.com]
Sent: Thursday, October 04, 2001 10:28 AM[Barry Jia]  
To: 'ant-user@jakarta.apache.org'
Subject: How to Run Auto Build


H i, All, 
I wrote a batch file to run my build, I want to run it automatically at
middle night at WINNT, I use at command to schedule a task, it does not
work. The job is invoked but it looks not run my build, any idea ?

Thanks! 

Barry 




Mime
View raw message