ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Taylor <donald_l_taylor...@yahoo.com>
Subject Re: Problem with classpath - newbie
Date Thu, 11 Oct 2001 12:34:43 GMT
Try replacing

<pathelement location="${build.jarpath}/${app.name}.jar" />

with 

<fileset dir="${build.jarpath}">
    <include name="${app.name}.jar" />
</fileset>

-- Don

--- Kalyan Dasika <Kalyan.Dasika@silverline.com> wrote:
> Hi,
> I have a classpath problem... 
> 
> This is a error part of the messages that i get when i run, ant
> -verbose
> from the command line.
> 
>      [java] Calling com.test.HelloWorld
>      [java] Java args: []
> 
> BUILD FAILED
> 
> build.xml:30: Could not find com.test.HelloWorld. Make sure you have
> it
> in your
> classpath
> 
> 
> The target in the build.xml that i am using which executes the above
> class.
> 
> 	<target name="executesrc" depends="compilesrc,compiletests"
> if="junit.present">
> 		<java classname="com.test.HelloWorld">
> 			<classpath>
> 				<pathelement
> location="${build.jarpath}/${app.name}.jar" />
> 				<pathelement path="" />
> 				<pathelement path="${java.class.path}"
> />			
> 			</classpath>
> 		</java>
> 	</target>
> 
> I have the class, com.test.HelloWorld in the jar file which i had set
> in
> the classpath of the build.xml
> 
> Due to some reason the jar file is not being set in the classpath..
> is
> there any else that i need to do? Could some one give suggestions?
> 
> Regards,
> Kalyan


__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

Mime
View raw message