ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From detlef.bren...@canoo.com
Subject Re: JAVAMAIL problem
Date Wed, 03 Oct 2001 07:30:09 GMT
I tried to send a zip-file with the mimetype "application/zip" and Javamail or
Jaf caused a mimetype exception.
the zip file isnt too big (about 500k) so size shouldnt be an issue.

detlef
Quoting Erik Hatcher <jakarta-ant@ehatchersolutions.com>:

> Phil,
> 
> I just tried a modified (for my environment) version of your example
> using
> Ant 1.4:
> 
> <project default="testmail">
>   <target name="testmail">
>       <mimemail messageMimeType="text/plain"
>                 message="message"
>                 tolist="jakarta-ant@ehatchersolutions.com"
>                 subject="subject"
>                 from="jakarta-ant@ehatchersolutions.com"
>                 mailhost="mymailserver">
>          <fileset dir=".">
>             <include name="test.txt"/>
>          </fileset>
>       </mimemail>
>       <mimemail messageMimeType="text/html"
>                 messageFile="test.html"
>                 tolist="jakarta-ant@ehatchersolutions.com"
>                 subject="subject"
>                 from="jakarta-ant@ehatchersolutions.com"
>                 mailhost="mymailserver">
>       </mimemail>
>   </target>
> </project>
> 
> and it all worked fine.   Here are the results:
> 
> Buildfile: build.xml
> 
> testmail:
>  [mimemail] sending email
>  [mimemail] sending email
> 
> BUILD SUCCESSFUL
> 
> Total time: 4 seconds
> 
> Is there anything special about the file you are attempting to send?  
> Is it
> large?   It could be an issue with the JAF relating to your environment
> perhaps.   Let me know if you have any other clues to help resolve this.
> 
>     Erik
> 
> 
> ----- Original Message -----
> From: <philippe.lavoie@cactus.ca>
> To: <ant-user@jakarta.apache.org>
> Sent: Tuesday, October 02, 2001 8:17 AM
> Subject: RE: JAVAMAIL problem
> 
> 
> > I tried specifiying the mail host and it didn't help :(
> >
> > It works with text/plain but not text/html... I have no clue what the
> html
> > part changes but it's enough so that the socket gets closed...
> >
> > Here is the result with -debug
> 
> 
> 

Mime
View raw message