Fellow Ant Users,
 
The rmic task seems to work for me only when I do not try to use the weblogic rmic compiler. If I set the magic property build.rmic=weblogic in an external user.properties file, I see the following error output:
 
--------------------------------------------------------------------------------------------------------------------------------------------
     [rmic] RMI Compiling 1 class to C:\latest\starman\Build\startup
     [rmic] Class not found : com.stargus.platform.framework.topology.RemoteTopologyMgrImpl
 
BUILD FAILED
 
C:\latest\starman\projects\Master\front_end.xml:396: Error starting WebLogic rmic:
--------------------------------------------------------------------------------------------------------------------------------------------
 
For whatever reason, the task ceases to be able to locate the class, although it is there, and cannot invoke the weblogic rmic class for an unspecified reason. C:\bea\wlserver6.0\lib\weblogic.jar is appended to my system CLASSPATH. I have also tried placing weblogic.jar in C:\ant\lib (a.k.a. ANT_HOME) and setting includeJavaRuntime="yes" in the task to no avail. The relevant build.xml snippet is as follows:
 
  <rmic base="${startup}"
        classname="com.stargus.platform.framework.topology.RemoteTopologyMgrImpl">
    <classpath refid="startupcp"/>
  </rmic>
 
I am quite sure the issues I am having are due to operator error(s) and that I am overlooking some fundamental configuration or code error, but I am baffled. Does anyone have any insight?
 
Cheers,
 
Matt
-----Original Message-----
From: Phil Beiler [mailto:phil_beiler@fanniemae.com]
Sent: Tuesday, September 04, 2001 8:55 AM
To: ANT User Group
Subject: Ant 1.4, RMIC, and weblogic....

The new rmic task worked like a champ, but I see no way to provide options to the weblogic.rmic command?  Specifically, I need to specify the -clusterable option...
 
What am I missing?
 
Thanks. Phil