ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject RE: Ant 1.4, RMIC, and weblogic....
Date Tue, 04 Sep 2001 23:18:47 GMT
Daniel,

I committed the patch you provided and it should be in the 1.4 build. This
was for the arguments to the compiler. The classpath issues, I deferred.

Conor


-----Original Message-----
From: Daniel Hoppe [mailto:hoppe@sitewaerts.de]
Sent: Wednesday, 5 September 2001 6:45 AM
To: 'ant-user@jakarta.apache.org'
Subject: RE: Ant 1.4, RMIC, and weblogic....


Hi,

I posted this as a problem on ant-dev a week ago. For me it won't run if I
don't put the weblogic stuff into the ant lib directory. I looked at the
code and it seems that the actual compiler will not use the nested classpath
(I might be wrong here, not too sure). The problem is that the weblogic 6.1
libs break other functionality. The task from the CVS had another problem, I
think it was broken. I sent what I think is a correction, but I guess that
due to the 1.4 release stress noone looked at it until now.

You can try to put weblogic.jar into the ant lib directory, again, other
tasks - especially xml related things - might fail if you do...

Daniel

-----Original Message-----
From: Phil Beiler [mailto:phil_beiler@fanniemae.com]
Sent: Tuesday, September 04, 2001 8:25 PM
To: ant-user@jakarta.apache.org
Subject: RE: Ant 1.4, RMIC, and weblogic....


I must have been seeing things this morning, because as soon as I mailed my
earlier question (about clustering options) I am now getting the same error
as Matt... I have not been able to make it work again today...

So any information on this problem would also be helpful...

Phil


     [rmic]
com\fanniemae\customersolutions\ce\webapp\service\PropertiesServiceImpl.clas
s added as
c:\opt\Deploy\.build\webapp\com\fanniemae\customersolutions\ce\webapp\servic
e\PropertiesServiceImpl_WLStub.class doesn't exist.
     [rmic] RMI Compiling 1 class to \opt\Deploy\.build\webapp
     [rmic] Using WebLogic rmic
     [rmic] Compilation args: -noexit -d
c:\opt\Deploy\.build\webapp -classpath
c:\opt\Deploy\.build\webapp;C:\opt\jakarta-log4j1.0.4\dist\lib\log4j.jar;C:\
opt\jakarta-struts-1.0\lib\struts.jar;C:\opt\xerces-1_3_\xerces.jar;C:\opt\w
eblogic\classes;C:\opt\weblogic\lib\weblogicaux.jar;C:\opt\Deploy\.build\web
app;C:\Packages\jdk1.3\lib\tools.jar;C:\opt\jakarta-ant-1.4\lib\jaxp.jar;C:\
opt\jakarta-ant-1.4\lib\jakarta-ant-1.4-optional.jar;C:\opt\jakarta-ant-1.4\
lib\crimson.jar;C:\opt\jakarta-ant-1.4\lib\ant.jar
     [rmic] File to be compiled:
com.fanniemae.customersolutions.ce.webapp.service.PropertiesServiceImpl

BUILD FAILED

C:\home\sxupjb\Source\CE\src\webapp\local.build.xml:41: Cannot use WebLogic
rmic, as it is not available A common solution is to set the environment
variable CLASSPATH.




-----Original Message-----
From: Matt Lyon [mailto:matt@stargus.com]
Sent: Tuesday, September 04, 2001 1:26 PM
To: ant-user@jakarta.apache.org
Subject: RE: Ant 1.4, RMIC, and weblogic....


Fellow Ant Users,

The rmic task seems to work for me only when I do not try to use the
weblogic rmic compiler. If I set the magic property build.rmic=weblogic in
an external user.properties file, I see the following error output:

----------------------------------------------------------------------------
----------------------------------------------------------------
     [rmic] RMI Compiling 1 class to C:\latest\starman\Build\startup
     [rmic] Class not found :
com.stargus.platform.framework.topology.RemoteTopologyMgrImpl

BUILD FAILED

C:\latest\starman\projects\Master\front_end.xml:396: Error starting WebLogic
rmic:
----------------------------------------------------------------------------
----------------------------------------------------------------

For whatever reason, the task ceases to be able to locate the class,
although it is there, and cannot invoke the weblogic rmic class for an
unspecified reason. C:\bea\wlserver6.0\lib\weblogic.jar is appended to my
system CLASSPATH. I have also tried placing weblogic.jar in C:\ant\lib
(a.k.a. ANT_HOME) and setting includeJavaRuntime="yes" in the task to no
avail. The relevant build.xml snippet is as follows:

  <rmic base="${startup}"

classname="com.stargus.platform.framework.topology.RemoteTopologyMgrImpl">
    <classpath refid="startupcp"/>
  </rmic>

I am quite sure the issues I am having are due to operator error(s) and that
I am overlooking some fundamental configuration or code error, but I am
baffled. Does anyone have any insight?

Cheers,

Matt
-----Original Message-----
From: Phil Beiler [mailto:phil_beiler@fanniemae.com]
Sent: Tuesday, September 04, 2001 8:55 AM
To: ANT User Group
Subject: Ant 1.4, RMIC, and weblogic....


The new rmic task worked like a champ, but I see no way to provide options
to the weblogic.rmic command?  Specifically, I need to specify
the -clusterable option...

What am I missing?

Thanks. Phil


<<<<<<<<<<<<<<<<<<<<<<<<<<<
sitewaerts GmbH
Hebelstra├če 15
D-76133 Karlsruhe


Tel: +49 (721) 920 918 0
Fax: +49 (721) 920 918 29
http://www.sitewaerts.de
>>>>>>>>>>>>>>>>>>>>>>>>>>>


Mime
View raw message