ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Beiler" <phil_bei...@fanniemae.com>
Subject RE: Ant 1.4, RMIC, and weblogic....
Date Tue, 04 Sep 2001 18:25:05 GMT
I must have been seeing things this morning, because as soon as I mailed my
earlier question (about clustering options) I am now getting the same error
as Matt... I have not been able to make it work again today...

So any information on this problem would also be helpful...

Phil


     [rmic]
com\fanniemae\customersolutions\ce\webapp\service\PropertiesServiceImpl.clas
s added as
c:\opt\Deploy\.build\webapp\com\fanniemae\customersolutions\ce\webapp\servic
e\PropertiesServiceImpl_WLStub.class doesn't exist.
     [rmic] RMI Compiling 1 class to \opt\Deploy\.build\webapp
     [rmic] Using WebLogic rmic
     [rmic] Compilation args: -noexit -d
c:\opt\Deploy\.build\webapp -classpath
c:\opt\Deploy\.build\webapp;C:\opt\jakarta-log4j1.0.4\dist\lib\log4j.jar;C:\
opt\jakarta-struts-1.0\lib\struts.jar;C:\opt\xerces-1_3_\xerces.jar;C:\opt\w
eblogic\classes;C:\opt\weblogic\lib\weblogicaux.jar;C:\opt\Deploy\.build\web
app;C:\Packages\jdk1.3\lib\tools.jar;C:\opt\jakarta-ant-1.4\lib\jaxp.jar;C:\
opt\jakarta-ant-1.4\lib\jakarta-ant-1.4-optional.jar;C:\opt\jakarta-ant-1.4\
lib\crimson.jar;C:\opt\jakarta-ant-1.4\lib\ant.jar
     [rmic] File to be compiled:
com.fanniemae.customersolutions.ce.webapp.service.PropertiesServiceImpl

BUILD FAILED

C:\home\sxupjb\Source\CE\src\webapp\local.build.xml:41: Cannot use WebLogic
rmic, as it is not available A common solution is to set the environment
variable CLASSPATH.




  -----Original Message-----
  From: Matt Lyon [mailto:matt@stargus.com]
  Sent: Tuesday, September 04, 2001 1:26 PM
  To: ant-user@jakarta.apache.org
  Subject: RE: Ant 1.4, RMIC, and weblogic....


  Fellow Ant Users,

  The rmic task seems to work for me only when I do not try to use the
weblogic rmic compiler. If I set the magic property build.rmic=weblogic in
an external user.properties file, I see the following error output:

  --------------------------------------------------------------------------
------------------------------------------------------------------
       [rmic] RMI Compiling 1 class to C:\latest\starman\Build\startup
       [rmic] Class not found :
com.stargus.platform.framework.topology.RemoteTopologyMgrImpl

  BUILD FAILED

  C:\latest\starman\projects\Master\front_end.xml:396: Error starting
WebLogic rmic:
  --------------------------------------------------------------------------
------------------------------------------------------------------

  For whatever reason, the task ceases to be able to locate the class,
although it is there, and cannot invoke the weblogic rmic class for an
unspecified reason. C:\bea\wlserver6.0\lib\weblogic.jar is appended to my
system CLASSPATH. I have also tried placing weblogic.jar in C:\ant\lib
(a.k.a. ANT_HOME) and setting includeJavaRuntime="yes" in the task to no
avail. The relevant build.xml snippet is as follows:

    <rmic base="${startup}"

classname="com.stargus.platform.framework.topology.RemoteTopologyMgrImpl">
      <classpath refid="startupcp"/>
    </rmic>

  I am quite sure the issues I am having are due to operator error(s) and
that I am overlooking some fundamental configuration or code error, but I am
baffled. Does anyone have any insight?

  Cheers,

  Matt
    -----Original Message-----
    From: Phil Beiler [mailto:phil_beiler@fanniemae.com]
    Sent: Tuesday, September 04, 2001 8:55 AM
    To: ANT User Group
    Subject: Ant 1.4, RMIC, and weblogic....


    The new rmic task worked like a champ, but I see no way to provide
options to the weblogic.rmic command?  Specifically, I need to specify
the -clusterable option...

    What am I missing?

    Thanks. Phil

Mime
View raw message