ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Dyke <>
Subject FTP put problems
Date Tue, 18 Sep 2001 11:23:25 GMT
I'm using the following test script to ftp files up to a server

<project name="fakebuild" default="ftp" basedir=".">

  <target name="" if="ftp">
    <available file="" property=""/>

  <target name="ftp" depends=""
    <property file=""/>
    <ftp server="${ftp.server}" userid="${ftp.userid}"
         action="put" binary="yes" verbose="yes">
      <fileset dir=".">
        <include name="*.xml"/>


Running the command line ant -buildfile ftp-test.xml -Dftp=yes -debug
results in the following:

Ant version 1.4 compiled on September 3 2001
Ant version 1.4 compiled on September 3 2001
Buildfile: ftp-test.xml
Detected Java version: 1.3 in: c:\jdk1.3\jre
Detected OS: Windows NT
parsing buildfile D:\ant\1.4\bin\ftp-test.xml with URI =
Project base dir set to: D:\ant\1.4\bin
Build sequence for target `ftp' is [, ftp]
Complete build sequence is [, ftp]

 [property] Loading D:\ant\1.4\bin\
      [ftp] Opening FTP connection to
      [ftp] connected
      [ftp] logging in to FTP server
      [ftp] login succeeded
      [ftp] disconnecting


Total time: 1 second

No files are uploaded however. Snooping the ftp port at the server end also
confirms that everything apart from the upload goes ok. I'm guessing the
is my <fileset> but can anyone confirm this or suggest an alternative

Will Dyke

This e-mail, and any attachment, is confidential. If you have received
it in error, please delete it from your system, do not use or disclose
the information in any way, and notify me immediately. The contents of
this message may contain personal views which are not the views of the
BBC, unless specifically stated.

View raw message