ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Rogers" <jason.rog...@tumbleweed.com>
Subject RE: need help with email listener
Date Fri, 14 Sep 2001 20:58:02 GMT
Ant1.3.  I have ant 1.4, so I will switch to that and see if it works.

Thanks.

-Jason

    > -----Original Message-----
    > From: SAINI,DEEPA (Non-A-PaloAlto,ex2)
    > [mailto:deepa_saini@non.agilent.com]
    > Sent: Friday, September 14, 2001 4:45 PM
    > To: 'ant-user@jakarta.apache.org'
    > Subject: RE: need help with email listener
    > 
    > 
    > I too was facing the same problem of not receiving any 
    > mail from the
    > BuildListener class when everything seemed to be correct. 
    > But it just
    > disappeared of its own when I upgraded to Ant 1.4 and I 
    > started getting the
    > mails.
    > 
    > What version are u using?
    > 
    > Deepa.
    > 
    > -----Original Message-----
    > From: Jason Rogers [mailto:jason.rogers@tumbleweed.com]
    > Sent: Friday, September 14, 2001 10:45 AM
    > To: 'Erik Hatcher'
    > Cc: Ant Users (E-mail)
    > Subject: RE: need help with email listener
    > 
    > 
    > I have tried what you suggest here Erik.
    > 
    > What it boils down to...
    > 
    > I put in debug statements everywhere except the moon.  
    > Everything looks fine
    > until I get to the part in the buildFinished(BuildEvent) 
    > method where it
    > constructs a MimeMessage.  It never gets past that part.  
    > I can't figure it
    > out!
    > 
    > Any help is much appreciated!
    > 
    > -Jason
    > 
    >     > -----Original Message-----
    >     > From: Erik Hatcher 
    > [mailto:jakarta-ant@ehatchersolutions.com]
    >     > Sent: Friday, September 14, 2001 10:22 AM
    >     > To: jason.rogers@tumbleweed.com
    >     > Subject: Re: need help with email listener
    >     > 
    >     > 
    >     > Try adding some debugging output to your BuildMonitor 
    >     > code and see what it
    >     > thinks of the properties its reading and such.
    >     > 
    >     > We have that BuildMonitor working on our integration 
    >     > server (although its
    >     > running Ant 1.3, I believe).   We customized the code for 
    >     > it somewhat
    >     > though, so perhaps we fixed something that wasn't correct 
    >     > like how it finds
    >     > the properties file and such.
    >     > 
    >     >     Erik
    >     > 
    >     > 
    >     > ----- Original Message -----
    >     > From: "Jason Rogers" <jason.rogers@tumbleweed.com>
    >     > To: <ant-user@jakarta.apache.org>
    >     > Sent: Friday, September 14, 2001 7:01 AM
    >     > Subject: RE: need help with email listener
    >     > 
    >     > 
    >     > > Yes I have the activation.jar on my classpath. :(
    >     > >
    >     > >     > -----Original Message-----
    >     > >     > From: Erik Hatcher 
    >     > [mailto:jakarta-ant@ehatchersolutions.com]
    >     > >     > Sent: Friday, September 14, 2001 9:46 AM
    >     > >     > To: ant-user@jakarta.apache.org
    >     > >     > Subject: Re: need help with email listener
    >     > >     >
    >     > >     >
    >     > >     > Do you have Sun's activation.jar in your 
    > classpath when
    >     > >     > you run Ant?
    >     > >     >
    >     > >     > You'll need that.   Its available at:
    >     > >     > 
    > http://java.sun.com/products/javabeans/glasgow/jaf.html
    >     > >     >
    >     > >     > One thing I have on my Ant to-do list is to submit a
    >     > >     > version of that e-mail
    >     > >     > code to be included in the Ant core 
    > distribution since
    >     > >     > its a very commonly
    >     > >     > requested feature.   The particular code 
    > that is in the
    >     > >     > Ant FAQ probably
    >     > >     > will need to be modified to use the older 
    > Java 1.1 way of
    >     > >     > sending an e-mail
    >     > >     > rather than using JAF (all it does is put 
    > text in the
    >     > >     > body of the message,
    >     > >     > does not make an attachment anyway).
    >     > >     >
    >     > >     > I'm also considering modifying Ant such that build
    >     > >     > listeners can be attached
    >     > >     > dynamically through build.xml definitions (the main
    >     > >     > caveat is that at the
    >     > >     > very least the build started message would 
    > not be sent to
    >     > >     > those listeners).
    >     > >     >
    >     > >     >     Erik
    >     > >     >
    >     > >     > ----- Original Message -----
    >     > >     > From: "Jason Rogers" <
    >     > >     > To: "Ant Users (E-mail)" 
    > <ant-user@jakarta.apache.org>
    >     > >     > Cc: <will.glozer@jda.com>
    >     > >     > Sent: Friday, September 14, 2001 6:22 AM
    >     > >     > Subject: need help with email listener
    >     > >     >
    >     > >     >
    >     > >     > > Below is my ant commandline and output.  
    > I am having
    >     > >     > trouble with the
    >     > >     > > listener.  The trouble is that it isn't 
    > complaining
    >     > >     > about anything being
    >     > >     > > wrong at runtime, but it doesn't send the 
    > email.  I
    >     > >     > have done independent
    >     > >     > > validations on the smtp server and email 
    > address found
    >     > >     > in the properties
    >     > >     > > file to prove that they are correct.  With those
    >     > >     > validations I receive the
    >     > >     > > email as I think I should.  What makes me think 
    >     > that all is not
    >     > >     > "hunky-dory"
    >     > >     > > with the monitor is that after the build 
    > I see the line
    >     > >     > > "javax/activation/DataSource"...  Has 
    > anyone run into
    >     > >     > this before?  I am
    >     > >     > > also including the contents of my 
    > monitor.properties
    >     > >     > file after the build
    >     > >     > > info.  Thanks in advance!
    >     > >     > >
    >     > >     > > -Jason
    >     > >     > >
    >     > >     > > <build_info>
    >     > >     > > ant -Dbasedir=/working -Dtests.notrequired=true
    >     > >     > -Dcvs.noupdate=true
    >     > >     > > -listener BuildMonitor -logfile build.log
    >     > >     > > Buildfile: build.xml
    >     > >     > >
    >     > >     > > init:
    >     > >     > >      [echo] Built on September 14 2001 at 0912
    >     > >     > >
    >     > >     > > co:
    >     > >     > >
    >     > >     > > mkdirs:
    >     > >     > >     [mkdir] Created dir:
    >     > >     > C:\working\Apps\PostOffice\build\classes
    >     > >     > >
    >     > >     > > src:
    >     > >     > >     [javac] Compiling 46 source files to
    >     > >     > > C:\working\Apps\PostOffice\build\classes
    >     > >     > >       [jar] Building jar:
    >     > >     > > 
    > C:\working\Apps\PostOffice\build\lib\postoffice.jar
    >     > >     > >
    >     > >     > > samples:
    >     > >     > >     [javac] Compiling 12 source files to
    >     > >     > > C:\working\Apps\PostOffice\build\classes
    >     > >     > >       [jar] Building jar:
    >     > >     > > 
    >     > C:\working\Apps\PostOffice\build\lib\postofficeSamples.jar
    >     > >     > >
    >     > >     > > tests:
    >     > >     > >
    >     > >     > > javadoc_check:
    >     > >     > >
    >     > >     > > javadocs:
    >     > >     > >
    >     > >     > > clean:
    >     > >     > >    [delete] Deleting directory
    >     > >     > C:\working\Apps\PostOffice\build\classes
    >     > >     > >
    >     > >     > > BUILD SUCCESSFUL
    >     > >     > >
    >     > >     > > Total time: 7 seconds
    >     > >     > > javax/activation/DataSource
    >     > >     > > </build_info>
    >     > >     > >
    >     > >     > > <props_file>
    >     > >     > > # configuration for build monitor
    >     > >     > >
    >     > >     > > mail.transport.protocol=smtp
    >     > >     > > mail.smtp.host=exch.mi.tumbleweed.com
    >     > >     > > mail.from=Jason Rogers <jrog@intface.com>
    >     > >     > >
    >     > >     > > build.log=build.log
    >     > >     > >
    >     > >     > > build.failed.notify=true
    >     > >     > > build.failed.email.to=jrog@intface.com
    >     > >     > > build.failed.email.subject=Nightly build failed!
    >     > >     > >
    >     > >     > > build.succeeded.notify=true
    >     > >     > > build.succeeded.email.to=jrog@intface.com
    >     > >     > > build.succeeded.email.subject=Nightly 
    > build succeeded!
    >     > >     > > </props_file>
    >     > >     > >
    >     > >     > >
    >     > >     >
    >     > >     >
    >     > >     >
    >     > >
    >     > >
    >     > 
    >     > 
    >     > 
    > 
    > 


Mime
View raw message