ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Getchell <Ad...@hrrm.ucdavis.edu>
Subject RE: Using ant to build imjay
Date Mon, 10 Sep 2001 22:51:08 GMT
I'm using ant 1.4.

I took your advice and turned off echo'ing. The error was an unquoted
argument for the java path.

My java path seemed to be messed up, so I reinstalled the JDK version
1.3.1_01 in c:\jdk1.3.1_01 and did:

set JAVA_HOME=c:\jdk1.3.1_01

then did in c:\temp\imjay-0.3.1

ant -buildfile imjay.xml

which resulted in:

Buildfile: imjay.xml

BUILD FAILED

C:\temp\imjay-0.3.1\imjay.xml:2: Config file is not of expected XML type

Total time: 0 seconds

I wonder if this is an ant problem ...


***************************	
*	Adam Getchell
AdamG@hrrm.ucdavis.edu
*	System Architect/Programmer			(530) 752-1584
*	Human Resources Information Systems	http://www.hr.ucdavis.edu/
***************************	
"Invincibility is in oneself, vulnerability in the opponent." -- Sun Tzu


-----Original Message-----
From: Diane Holt [mailto:holtdl@yahoo.com] 
Sent: Friday, September 07, 2001 8:05 AM
To: ant-user@jakarta.apache.org
Subject: Re: Using ant to build imjay

Adam,

Try turning echo'ing on in your ant.bat so you can see where it's
breaking. The "'c:Program' is not recognized..." looks like something
needs quoting to hold things with spaces together, but I thought all of
that had been fixed for 1.4 -- are you running 1.4?

Diane

--- Adam Getchell <AdamG@hrrm.ucdavis.edu> wrote:
> Hello all,
> 
> I seem to be having difficulties using ant to build imjay
> (imjay.sourceforge.org), a secure Java instant messaging client. I'm on
> Windows 2000 Pro, SP2.
> 
> Following the instructions on the FAQ
> (http://jakarta.apache.org/ant/manual/index.html), I unzipped ant into
> c:\utilities\ant.
> 
> Then I did:
> 
> set ANT_HOME=c:\utilities\ant
> set PATH=%PATH%;%ANT_HOME%\bin
> 
> (The instructions indicated that setting JAVA_HOME was optional, and
> when I
> did so the outcome did not change.)
> 
> Now, I also unzipped imjay into c:\temp 
> 
> And did:
> 
> ant -buildfile imjay.xml
> 
> which returns:
> 'c:\Program' is not recognized as an internal or external command,
> operable
> program or batch file.
> 
> The contents of my System Path variable is:
> C:\IBM
>
Connectors\Encina\bin;;C:\PROGRA~1\Borland\Delphi5\Projects\Bpl;C:\PROGRA~1\
>
Borland\vbroker\jre\Bin;C:\PROGRA~1\Borland\vbroker\Bin;C:\PROGRA~1\Borland\
>
Delphi5\Bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:
> \Program Files\Microsoft SQL Server\80\Tools\BINN
> 
> The contents of my user PATH variable is:
> 
> C:\Program Files\SSH Communications Security\SSH Secure
> Shell;C:\Utilities\ant
> 
> What am I missing?
> 
> I also tried using the AntRunner OpenTool plugin for JBuilder,
> installing
> according to the directions, but when I get to configuring the AntNode
> it
> gives me a "Buildfile has no targets". However, that's probably the
> subject
> of another question; I only mention it for completeness.
> 
> Thanks all,
> 
> ***************************	
> *	Adam Getchell
> AdamG@hrrm.ucdavis.edu
> *	System Architect/Programmer			(530) 752-1584
> *	Human Resources Information Systems
> http://www.hr.ucdavis.edu/
> ***************************	
> "Invincibility is in oneself, vulnerability in the opponent." -- Sun Tzu
> 
> 
> 


=====
(holtdl@yahoo.com)



__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com

Mime
View raw message