ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: Manifest bug?
Date Fri, 21 Sep 2001 16:30:53 GMT
On Sat, 22 Sep 2001 02:15, Richard Wilkinson wrote:
> Can anyone confirm a JAR manifest bug when creating a JAR file.
> The Ant 1.4 manifest file truncates the lines to a fixed size, replacing
> the remainder on the next line (see below)
>
> Manifest-Version: 1.0
> Created-By: Ant 1.4
>
> Name: com/protek/sp/equipment/EquipmentDefinitionBeanEOImpl_WLStub.cla
>  ss
>
> Name: com/protek/sp/enumerators/BandwidthTypeManagerBeanHomeImpl_WLSke
>  l.class
>
> Name: com/protek/sp/enumerators/ManufacturerManagerBeanEOImpl_Descript
>  or.ser

expected behaviour.

> We have a rebuild process that reduces the bean deployment, as part of the
> process the product JAR file previous created is extracted (using Ant) to a
> temporary directory. The newly compiled files a copied to the temporary
> directory. The temporary directory is JAR again. It works the first time,
> but it fails further times and the manifest file appears as above.
>
> Has anyone else seen this? If so is there a fix?

I am not sure what you mean. Do you mean that the above file will not feed 
back into jar task ?

-- 
Cheers,

Pete

------------------------------------------------------------
 I just got lost in thought... It was unfamiliar territory.
------------------------------------------------------------

Mime
View raw message