ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jp Morgan <jpmorg...@yahoo.com>
Subject Re: Ant 1.4 question with usage in JBoss
Date Wed, 19 Sep 2001 01:16:32 GMT
IT WORKED !!!!

--- Diane Holt <holtdl@yahoo.com> wrote:
> --- jp Morgan <jpmorganh@yahoo.com> wrote:
> > I had problem with the same exception. But when I
> > changed line 16 to the following line everything
> > worked. I just added the value attribute.
> > 
> >  <property name="env" environment="env"
> value="env" />
> 
> That's not the right solution, and probably
> shouldn't really work
> (although it does save typing another <property>
> task :) What you've done
> in the above is to both load your environment
> variables in as properties
> that are prefixed with "env" (eg., you'd reference
> your HOME environment
> variable as ${env.HOME}), as well as to set an
> actual property called
> "env" to the value "env".  (Guess we need to decide
> whether it's okay to
> allow a single <property> task to both set a
> property and load in the
> environment vars or to beef up the error-checking
> for <property>.)
> 
> Diane
> 
> 
> =====
> (holtdl@yahoo.com)
> 
> 
> 
> __________________________________________________
> Terrorist Attacks on U.S. - How can you help?
> Donate cash, emergency relief information
>
http://dailynews.yahoo.com/fc/US/Emergency_Information/


__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/

Mime
View raw message