ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Hatcher" <jakarta-...@ehatchersolutions.com>
Subject Re: trying o log in cvs pserver with ant's task cvs/cvspass
Date Mon, 10 Sep 2001 00:50:01 GMT
Looks as though CVS is not in your path.   Try running CVS from the
command-line and see what happens.

The CVS command-line utility must be installed and in your path in order for
the Ant <cvs> task to work.

    Erik

----- Original Message -----
From: "Guan, Kelly" <C_Kelly.Guan@wingcast.com>
To: <ant-user@jakarta.apache.org>
Sent: Sunday, September 09, 2001 3:40 PM
Subject: trying o log in cvs pserver with ant's task cvs/cvspass


Hi.
I am new to ant, and trying to use cvs login task to login in a remote
cvs pserver.
but I couldn't make it work using cvs task.
what I am doing is this:
<cvs command="login"
     cvsRoot=":pserver:machinename:repositorydir">
</cvs>
Also I tried to add CVS password after the cvsRoot, and no luck either.
I always get java ioException, error=2 back at createProcess.
And I tried <cvspass> task, seems this task didn't give me any error,
but when the execution moves
to next task - cvs checkout, I still get the java ioException, error=2
back.
So can <cvspass> be used to replace <cvs command="login"> ?
Well, I can't tell too much from the error I got back, but I think
properly I am missing something here.
I searched the emails, didn't see anyone else has the problem.
Any help is greatly appreciated.


kelly




Mime
View raw message