ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tait, Allen" <at...@IDEXX.com>
Subject CreateProcess Ant error=2
Date Wed, 29 Aug 2001 13:16:27 GMT
I am executing Ant with a build.xml file that uses exec to execute Ant again
on another build.xml that exists in a subdirectory.  This is on windows NT.
I am getting the following message:

e:\cvs\vetconnect\build.xml:39: Execute failed: java.io.IOException:
CreateProcess:
--- Nested Exception ---
java.io.IOException: CreateProcess: ant error=2
        at java.lang.Win32Process.create(Native Method)
        at java.lang.Win32Process.<init>(Win32Process.java:66)
        at java.lang.Runtime.execInternal(Native Method)
        at java.lang.Runtime.exec(Runtime.java:551)
        at java.lang.reflect.Method.invoke(Native Method)
        at
org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:363)
        at
org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:226)
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:242)
        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:162)
        at org.apache.tools.ant.Target.execute(Target.java:153)
        at org.apache.tools.ant.Project.runTarget(Project.java:908)
        at org.apache.tools.ant.Project.executeTarget(Project.java:536)
        at org.apache.tools.ant.Project.executeTargets(Project.java:510)
        at org.apache.tools.ant.Main.runBuild(Main.java:421)
        at org.apache.tools.ant.Main.main(Main.java:149)



Here is a piece of the build.xml:

  <target name="subprojects" depends="5min">
    <exec dir="content" executable="ant"/>
    <mkdir dir="${build.dir}/webapp/lab"/>
    <copy todir="${build.dir}/webapp/lab">
      <fileset dir="content/output"/>
    </copy>
    <exec dir="help" executable="ant"/>
    <mkdir dir="${build.dir}/webapp/help"/>
    <copy todir="${build.dir}/webapp/help">
      <fileset dir="help/output"/>
    </copy>
  </target>



This seems to be an environment issue.  I have Ant in my PATH.  Not sure why
this is failing.  Has anyone else worked through this?

Mime
View raw message