ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephane Bailliez <sbaill...@imediation.com>
Subject RE: JUnit tests fail -> build fail
Date Mon, 06 Aug 2001 09:30:41 GMT
> -----Original Message-----
> From: Klara Ward [mailto:klara.ward@debitech.com]

> I probably did something stupid. It works with ant 1.3 but I 
> can't 1.4 to
> work with junitreport, neither my old one(that once worked) 
> nor the new one.
> In my ant lib I have the jars ant, crimson, optional(the same 
> version as
> the ant1.4alpha, that is 2001-08-05), junit, xalan, xerces and
> cruisecontrol. Where exactly is junitreport defined?

The optional jar is probably not having the concerned classes...
As Stefan said, Best thing is to rebuild it from scratch.

Make sure that you have xalan 1.2.2 AND xerces.
http://xml.apache.org/xalan-j/dist/old/xalan-j_1_2_2.zip
Xerces is needed by Xalan 1.2.2 to perform serialization.

Another alternative is to rebuild it using xalancompat.jar from a xalan2
distrib...if you don't understand the issue here...it's probably better to
skip it..especially since there are some problems here and there w/ the
latest release..2.2D6 -> 2.2D8

> Did I loose some jar-file on the way, or what could I have done?
> It would be nice to have everything working at the same time...

It will. :)

-- 
 St├ęphane Bailliez 
 Software Engineer, Paris - France 
 iMediation - http://www.imediation.com 
 Disclaimer: All the opinions expressed above are mine and not those from my
company. 



Mime
View raw message