ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter.FL...@syntegra.com
Subject Conditional ANT building
Date Thu, 09 Aug 2001 15:02:28 GMT
Since some of the tasks differ between 1.3 and 1.4alpha/beta, I want to
perform different things for different ANT versions.  
I can obtain the ANT version using the property ant.java.version, but is
there some way to say:

if ${ant.java.version} == "1.3" 
   echo "Using ANT 1.3"
else if ${ant.java.version} == "1.4"
   do something else....


Is this possible?

Peter


********************************************************************

This email may contain information which is privileged or confidential. If you are not the
intended recipient of this email, please notify the sender immediately and delete it without
reading, copying, storing, forwarding or disclosing its contents to any other person
Thank you

Check us out at http://www.syntegra.com

********************************************************************

Mime
View raw message