ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cynthia He <...@Insight.com>
Subject RE: wlclasspath ??
Date Thu, 16 Aug 2001 18:38:32 GMT
This is a problem caused by your classpath when starting up weblogic.  The
EJB beans you deploy should be contained in the jar file in your application
directory only.  They should not be anywhere in the classpath, which means
that you should not put your ejb jar file in your classpath either.  I
usually generate two jars, one contains EJB only, the other contains any
other classes needed by your beans.
 
Hope this helps.

-----Original Message-----
From: Jamie Tsao [mailto:jtsao@atinera.com]
Sent: Wednesday, August 15, 2001 12:00 PM
To: ant-user@jakarta.apache.org
Subject: wlclasspath ??




Hi, 

I am able to successfully deploy weblogic-specific jars using the <ejbjar>
task with an included <weblogic> tag. 

Although I receive the following error: 

wlejb: [ejbjar] building UserEJB.jar with 7 files 
[ejbc] <Jun 12, 2001 10:39:49 AM PDT> <Error> <EJB> <EJB Deployment:
UserEJB
has a class com.xxx.entity.UserEJB which is in the classpath. This class
should only be located in the ejb-jar file.> 

It seems as though the deployed jar still works correctly. The ANT
documentation for the <weblogic> tag mentions something about this error in
relation to the wlclasspath attribute, but I don't quite understand it. Can
somebody explain this problem to me, and how I could possible fix it ?  Am I
suppose to only put the weblogic.jar in "wlclasspath" and everything else in
"classpath" ? I can probably ignore the error messages, but once again, they
are annoying. 

Thanks, 

Jamie 


Mime
View raw message