ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Goldstein <sdgol...@MailAndNews.com>
Subject Problems with Script task
Date Fri, 24 Aug 2001 18:24:01 GMT
I'm trying to run the script task and I get the following error:

--- Nested Exception ---
java.lang.IncompatibleClassChangeError
        at 
com.ibm.bsf.engines.javascript.JavaScriptEngine.initialize(JavaScriptEngine.ja
va, Compiled Code)
        at com.ibm.bsf.BSFManager.loadScriptingEngine(BSFManager.java:320)
        at com.ibm.bsf.BSFManager.exec(BSFManager.java:479)
        at org.apache.tools.ant.taskdefs.optional.Script.execute(Script.java, 
Compiled Code)
        at org.apache.tools.ant.Target.execute(Target.java, Compiled Code)
        at org.apache.tools.ant.Project.runTarget(Project.java:898)
        at org.apache.tools.ant.Project.executeTarget(Project.java, Compiled 
Code)
        at org.apache.tools.ant.Project.executeTargets(Project.java, Compiled 
Code)
        at org.apache.tools.ant.Main.runBuild(Main.java, Compiled Code)
        at org.apache.tools.ant.Main.main(Main.java:149)

I have added to my lib directory bsf.jar, js.jar, and optional.jar.  Is it 
possible that I'm using the wrong versions?  Does someone know what the 
correct versions are and where I could get them?

Thanks.

Scott

------------------------------------------------------------
"Just a mirror for the sun...
 My smiling eyes are just a mirror for the sun."
------------------------------------------------------------


Mime
View raw message