ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <blorit...@apache.org>
Subject Re: JUnit tests fail -> build fail
Date Mon, 06 Aug 2001 18:33:19 GMT
Klara Ward wrote:
> 
> Just to spam this list even further I'm not sure I tried junitreport with
> 1.4 at all. Has anyone else tried and got it to work?

I just sent in a patch that would make junitreport use the JAXP 1.1 API
for transformations.  It _should_ work with JDK 1.4 as well as Xalan 2.

> 
> Klara
> 
> > -----Original Message-----
> > From: Klara Ward [mailto:klara.ward@debitech.com]
> > Sent: den 6 augusti 2001 09:45
> > To: ant-user@jakarta.apache.org
> > Subject: RE: JUnit tests fail -> build fail
> >
> >
> > Great, now it works. I got a little nervous before I switched to
> > the correct
> > optional.jar... It's easy to forget it.
> >
> > Instead I now managed to destroy my junitreport:
> > C:\antdebitech\builddebitech2.xml:147: Could not create task of type:
> > junitreport. Common solutions
> > are to use taskdef to declare your task, or, if this is an
> > optional task, to
> > put the optional.jar i
> >  the lib directory of your ant installation (ANT_HOME).
> >         at
> > org.apache.tools.ant.UnknownElement.makeTask(UnknownElement.java:153)
> >         at
> > org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.java:83)
> >         at org.apache.tools.ant.Task.perform(Task.java:197)
> >         at org.apache.tools.ant.Target.execute(Target.java:164)
> >         at org.apache.tools.ant.Target.performTasks(Target.java:182)
> >         at org.apache.tools.ant.Project.executeTarget(Project.java:580)
> >         at org.apache.tools.ant.Project.executeTargets(Project.java:539)
> >         at org.apache.tools.ant.Main.runBuild(Main.java:453)
> >         at org.apache.tools.ant.Main.start(Main.java:154)
> >         at org.apache.tools.ant.Main.main(Main.java:177)
> >
> > Total time: 2 seconds
> >
> > I probably did something stupid. It works with ant 1.3 but I can't 1.4 to
> > work with junitreport, neither my old one(that once worked) nor
> > the new one.
> > In my ant lib I have the jars ant, crimson, optional(the same version as
> > the ant1.4alpha, that is 2001-08-05), junit, xalan, xerces and
> > cruisecontrol. Where exactly is junitreport defined?
> >
> > Did I loose some jar-file on the way, or what could I have done?
> >
> > It would be nice to have everything working at the same time...
> >
> > Klara
> >
> > > -----Original Message-----
> > > From: Stefan Bodewig [mailto:bodewig@apache.org]
> > > Sent: den 3 augusti 2001 14:44
> > > To: ant-user@jakarta.apache.org
> > > Subject: Re: JUnit tests fail -> build fail
> > >
> > >
> > > On Fri, 3 Aug 2001, Klara Ward <klara.ward@debitech.com> wrote:
> > >
> > > > So what do you think of this...
> > >
> > > Think you've discovered a bug and provided a good testcase for it,
> > > thanks.
> > >
> > > The appended patch that fixes the problem will be committed in a few
> > > minutes.
> > >
> > > Stefan
> > >
> > >
> > >
> >

Mime
View raw message