ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cedric Berger <ced...@wireless-networks.com>
Subject Re: Tar/Tarfileset broken on Ant 1.3 ?
Date Mon, 06 Aug 2001 16:24:08 GMT
Hi Stefan:

Stefan Bodewig wrote:

>There are bugs in Ant 1.3's tarfilest, but what you see is expected
>behavior:
>
>> <tar tarfile="${dist}/http-proxy.tar">
>>   <tarfileset dir="${build}/http.proxy" mode="755" username="0" group="0">
>>     <include name="${build}/http.proxy/**/*.sh"/>
>>   </tarfileset>
>>   <tarfileset dir="${build}/http.proxy" mode="644" username="0" group="0">
>>     <include name="{build}/http.proxy/**/*.jar"/>
>>   </tarfileset>
>> </tar>
>>
>
>The include pattern is supposed to be relative to the dir attribute -
>
This is not what the example in the documentation shows.
Please look at the example at the bottom of:
    http://jakarta.apache.org/ant/manual/CoreTasks/tar.html

>
>Ant doesn't find any files and therefore assumes the archive is
>up-to-date.
>
>Make that
>
> <tar tarfile="${dist}/http-proxy.tar">
>   <tarfileset dir="${build}/http.proxy" mode="755" username="0" group="0">
>     <include name="**/*.sh"/>
>   </tarfileset>
>   <tarfileset dir="${build}/http.proxy" mode="644" username="0" group="0">
>     <include name="**/*.jar"/>
>   </tarfileset>
> </tar>
>
If you look at (the bottom of) my original message, you will see that
I've tryed that too, and it didn't work neither.

Cedric



Mime
View raw message