ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Jacques Monnat ...@issolutions.com>
Subject RE: installation problems on windows 98
Date Tue, 07 Aug 2001 22:00:16 GMT
Hi Anke,

Where did unzip the zip files ? Don't unzip it
in a directory containing space char, like Program Files.

It's better straight in C:\, like the most of the java apps.

I had a similar problem because of one the class paths element 
did contain a space, ant was the first java app making problem
with this classpath, but it works fine now.

Best Regards
Jean-Jacques

-----Original Message-----
From: Anke ePost [mailto:anke.flechsig@epost.de]
Sent: Tuesday, August 07, 2001 2:40 PM
To: ant-user@jakarta.apache.org
Subject: AW: installation problems on windows 98


Hi Bill,

thanks for your reply, but I'm afraid, I had only problems with the
spelling:

my errormessage goes to org.apache.tools.ant.Main.

I only unzipped the file.

Anke

-----Urspr√ľngliche Nachricht-----
Von: Bill.J.Fellows@mail.sprint.com
[mailto:Bill.J.Fellows@mail.sprint.com]
Gesendet: Dienstag, 7. August 2001 23:20
An: ant-user@jakarta.apache.org
Betreff: RE: installation problems on windows 98


I'd check whatever file you are using to launch ant.  It looks like it
is trying to do something like
java org.pache.tools.ant.Main
instead of
java org.apache.tools.ant.Main

The ant.bat I have looks like
%_JAVACMD% -classpath %LOCALCLASSPATH% -Dant.home="%ANT_HOME%"
%ANT_OPTS% org.apache.tools.ant.Main %ANT_CMD_LINE_ARGS%

Have you fiddled with the ant.bat file?

/bill

-----Original Message-----
From: anke.flechsig [mailto:anke.flechsig@epost.de]
Sent: Tuesday, August 07, 2001 3:47 PM
To: ant-user
Subject: installation problems on windows 98


Hi,
I have a Windows 98 System and I loaded the last zip for ant 1.3.
I think my problem sounds a little like some of the other's with
problems
with the tar-file.
But not exactly ....

I try to test a simple Test-Programm and it dosn't work!
I set the PATH to Ant and JDK and set the ANT_HOME and JAVA_HOME
Variables.
I get the following Error message:
Exception in thread "main" java.lang.NoClassDefFoundError:
org/pache/tools/ant/Main
What did I miss to tell Ant where it lives?

I'm a little bit frustratet, because I only want to get Ant running, to
install JBoss and this is only the first step of many followings ...

Can anyone help me?
I would be very glad, if someone has a hint!

Thanks, Anke

Mime
View raw message