ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barry Jia <b...@brightspark.com>
Subject FW: Help need for Junitreport
Date Wed, 08 Aug 2001 19:10:31 GMT


Hi, I use my junitreport in my build.xml, I got following error, it happened
at 
 <report format="frames" todir="./"/>
I do not know what is problem. I tried both of xalan 2 and 1.2.2.
Thanks for help
Barry
----------- log --------------
D:\try1\PlayJunit\build.xml:49: java.lang.VerifyError: (class:
org/apache/tools/ant/taskdefs/option
l/junit/AggregateTransformer, method: getXSLStreamSource signature:
(Ljava/lang/String;)Lorg/apache
xalan/xslt/XSLTInputSource;) Incompatible object argument for function call
--- Nested Exception ---
java.lang.VerifyError: (class:
org/apache/tools/ant/taskdefs/optional/junit/AggregateTransformer, m
thod: getXSLStreamSource signature:
(Ljava/lang/String;)Lorg/apache/xalan/xslt/XSLTInputSource;) In
ompatible object argument for function call
        at
org.apache.tools.ant.taskdefs.optional.junit.XMLResultAggregator.createRepor
t(XMLResultA
gregator.java:114)
        at java.lang.reflect.Method.invoke(Native Method)
        at
org.apache.tools.ant.IntrospectionHelper$1.create(IntrospectionHelper.java:1
67)
        at
org.apache.tools.ant.IntrospectionHelper.createElement(IntrospectionHelper.j
ava:275)
        at
org.apache.tools.ant.ProjectHelper$NestedElementHandler.init(ProjectHelper.j
ava:535)
        at
org.apache.tools.ant.ProjectHelper$TaskHandler.startElement(ProjectHelper.ja
va:499)
        at
org.xml.sax.helpers.XMLReaderAdapter.startElement(XMLReaderAdapter.java:329)
        at
org.apache.xerces.parsers.SAXParser.startElement(SAXParser.java:1376)
        at
org.apache.xerces.validators.common.XMLValidator.callStartElement(XMLValidat
or.java:1191

        at
org.apache.xerces.framework.XMLDocumentScanner.scanElement(XMLDocumentScanne
r.java:1862)
        at
org.apache.xerces.framework.XMLDocumentScanner$ContentDispatcher.dispatch(XM
LDocumentSca
ner.java:1238)
        at
org.apache.xerces.framework.XMLDocumentScanner.parseSome(XMLDocumentScanner.
java:381)
        at org.apache.xerces.framework.XMLParser.parse(XMLParser.java:1081)
        at
org.xml.sax.helpers.XMLReaderAdapter.parse(XMLReaderAdapter.java:223)
        at javax.xml.parsers.SAXParser.parse(SAXParser.java:345)
        at org.apache.tools.ant.ProjectHelper.parse(ProjectHelper.java:117)
        at
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:85)
        at org.apache.tools.ant.Main.runBuild(Main.java:403)
        at org.apache.tools.ant.Main.main(Main.java:149)

-----Original Message-----
From: Berin Loritsch [mailto:bloritsch@apache.org]
Sent: Wednesday, August 08, 2001 1:59 PM
To: Barry Jia
Subject: Re: Help need for Junitreport


Barry Jia wrote:
> 
> Hi, Berin, Could you tell me how to integrate your patch to ant. I tried
to
> use junitreport in the ant , like this:
> 
>              <junitreport todir="./">
> 
>                   <fileset dir="./">
>                                 <include name="TEST-*.xml"/>
>                         </fileset>
> 
>                         <report format="frames" todir="./"/>
>                 </junitreport>
> how to make it work? I need to download new ant ? or new xalan,jar ? or
> something else ? I am new for XML and Ant, only one week experience,
please
> help !

Current CVS has the proper version to use either version of Xalan with
junitreport.

The XML you presented should work.

> Barry
> -----Original Message-----
> From: Berin Loritsch [mailto:bloritsch@apache.org]
> Sent: Wednesday, August 08, 2001 11:17 AM
> To: ant-user@jakarta.apache.org
> Subject: Re: Help need for Junitreport
> 
> Stephane Bailliez wrote:
> >
> 
> I proposed a patch to make JUnitReport work with Xalan 2.  Someone else
had
> something that made JUnitReport work with both Xalan 1 and Xalan 2.
> Hopefully
> one of those solutions will be put in CVS soon.
> 
> > You have to put xalan 1.2.2 jar in the optional directory of ant...same
> > place where junit is to enable the junit task.
> > Unless what the doc says it won't work with xalan 2.x compatibility jar
> > You can get the old xalan 1.2.2 here
> > http://xml.apache.org/dist/xalan-j/old/xalan-j_1_2_2.zip
> >
> > --
> >  St├ęphane Bailliez
> >  Software Engineer, Paris - France
> >  iMediation - http://www.imediation.com
> >  Disclaimer: All the opinions expressed above are mine and not those
from
> my
> > company.

Mime
View raw message