ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernd Gruendling <bernd.gruendl...@kontorist.de>
Subject Target 'build.xml' does not exist...
Date Tue, 03 Jul 2001 11:33:51 GMT
Hi,

I'm trying to set up my first ANT project. I started with this 
four-liner in a file called "simple.xml":

   <project default="whatever">
      <target name="whatever">
      </target>
   </project>

The currenct directory contained nothing but this. My first attempt was

   [d:\temp\anttest]ant
   Buildfile: build.xml does not exist!
   Build failed.

Well. I understand that: build.xml is the default name for the build 
file. Lets try

   [d:\temp\anttest]ant -buildfile simple.xml
   Buildfile: build.xml does not exist!
   Build failed.

Why does it insist on build.xml?


Lets rename simple.xml to build.xml:

   [d:\temp\anttest]ren simple.xml build.xml
   [d:\temp\anttest]ant
   Buildfile: build.xml

   BUILD FAILED

   Target 'build.xml' does not exist in this project.

Why does ANT confuse the build file and the target?

   [d:\temp\anttest]ant -buildfile build.xml
   Buildfile: build.xml

   BUILD FAILED

   Target 'build.xml' does not exist in this project.

Hm.

   [d:\temp\anttest]ant -help
   Buildfile: build.xml

   BUILD FAILED

   Target 'build.xml' does not exist in this project.


Time to go home.

What did I wrong?




Regards,
Bernd Gr√ľndling
_______________________________________________________________________
Bernd Gruendling                            Custom Software Development
Systemberatung Softwaredesign                    for Mac OS and Windows

Wendenstrasse 16                                Phone: +49 5363 97676-0
38448 Wolfsburg, Germany                    Facsimile: +49 5363 97676-9

Mime
View raw message