ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myron Uecker" <uec...@us.ibm.com>
Subject Re: OS/390, Ant 1.3 and Compiler Messages
Date Fri, 06 Jul 2001 12:06:11 GMT

>If you look below you will see two error messages. Namely
>
>> IOException getting canonical path for
>> /usr/lpp/WebSphere/AppServer/lib/jsdk.jar
>>
>> : bad path error
>>
>> IOException getting canonical path for
>> /usr/lpp/WebSphere/AppServer/lib/ibmwebas
>> .jar: bad path error
>
>This implies that the javac tool is never run as there is a problem
setting
>up ClassPath for these entries. Does
>/usr/lpp/WebSphere/AppServer/lib/jsdk.jar exist and is it readable? Is
there
>any other reason why java wouldn't be able to access that file?

The javac task and compiler do run, it ignores the two errors and continues
on.  If you recall in my first post I mentioned I had intentionally caused
a bug in the program.  If I take it out, I get this:

--------------------------------------------------
$ ant -buildfile MyClass.xml
Buildfile: MyClass.xml

prepare:

build:
    [javac] Compiling 1 source file to /u/muecke1/test
IOException getting canonical path for
/usr/lpp/WebSphere/AppServer/lib/jsdk.jar
: bad path error
IOException getting canonical path for
/usr/lpp/WebSphere/AppServer/lib/ibmwebas
.jar: bad path error

BUILD SUCCESSFUL

Total time: 10 seconds
--------------------------------------------------

I can try the patch mentioned by Stefan to see if it makes a difference.
Its possible those messages are causing javac to ignore the remaining
messages.  I'm running the binary distribution of Ant so I have a little
work to do before I can try the patch.

Myron Uecker
muecker@att.com



Mime
View raw message