ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myron Uecker" <uec...@us.ibm.com>
Subject OS/390, Ant 1.3 and Compiler Messages
Date Thu, 05 Jul 2001 19:28:07 GMT
I'm using Ant 1.3 to build code with JDK 1.1.8 and OS/390.  When javac
runs, it prints out messages for everything except the compiler output.  In
the output below, I'm building a simple class (15 lines) that has an
intentional error.  As you can see, I'm getting messages from javac that
I'm compiling one file, but there's no output from the compiler.  If I run
javac outside of Ant, I get the error messages.  I have tried using
-verbose and -debug settings and I see every message except the compiler
messages.  It appears that either the messages are not being written to the
output stream or the output stream is never being closed.

I tried the same command on my Windows 2000 workstation and I did get
compiler messages, so it has something to do with Ant running with IBM's
JDK under OS/390.

Has anybody else encountered this or found a solution?  Thank you.

------------------------------------------
$ ant -buildfile MyClass.xml
Buildfile: MyClass.xml

prepare:

build:
    [javac] Compiling 1 source file to /u/muecke1/test
IOException getting canonical path for
/usr/lpp/WebSphere/AppServer/lib/jsdk.jar
: bad path error
IOException getting canonical path for
/usr/lpp/WebSphere/AppServer/lib/ibmwebas
.jar: bad path error

BUILD FAILED

/u/muecke1/test/MyClass.xml:63: Compile failed, messages should have been
provided.

Total time: 5 seconds
------------------------------------------

Myron Uecker
muecker@att.com



Mime
View raw message