ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kit Cragin <kit.cra...@mongoosetech.com>
Subject RE: Can't Get an Ant-generated EAR to open with J2EE reference edition Deploytool
Date Sat, 14 Jul 2001 14:13:42 GMT
Have you found a resolution to this? I had a similar problem building a tag
library JAR. We ended up creating it manually at the end of our build and
putting it into souce control. Not pretty. For some reason the JDK's jar
command didn't work either. Structurally, the contents are identical.

- Kit

-----Original Message-----
From: Marc Rabil [mailto:marc.rabil@simplica.com]
Sent: Wednesday, July 11, 2001 7:17 PM
To: ant-user@jakarta.apache.org
Subject: Can't Get an Ant-generated EAR to open with J2EE reference
edition Deploytool


I can't seem to get an ear file created with ANT (v1.1 or 1.3) to open in
the reference implementation deploytool (version 1.2.1).  I am using Windows
2000 and have tried both JDK 1.3.0-C and 1.3.1.

I get a message window upon trying to open the ant-generated ear with
File>Open Application in the deploytool GUI saying: "myapp.ear does not
appear to be a valid application archive".

Oddly enough, if I create an ear in the deploytool (which can subsequently
be opened without a problem), extract its contents and then repackage those
exact same files using ANT it still doesn't work.  If I just use WinZip to
zip up these same files and then rename the zip as an ear it works fine!

Any help would be greatly appreciated.

Marc



Mime
View raw message