ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill.J.Fell...@mail.sprint.com
Subject RE: ANT telnet question
Date Tue, 24 Jul 2001 20:07:22 GMT
Do you have the netcomponents.jar available from 
www.savarese.org/oro/downloads
as referenced in http://jakarta.apache.org/ant/manual/install.html 

Just a thought...

/bill

-----Original Message-----
From: eric.youngquist [mailto:eric.youngquist@cisco.com]
Sent: Tuesday, July 24, 2001 3:01 PM
To: ant-user
Subject: ANT telnet question


Folks,

	I am trying use the optional task "telnet" and I get the following 
build
error below when I try process the following build.xml file.  Note: the
optional.tar file exists in the ant/lib directory and ANT_HOME is set
correctly.  (I dumped the LOCALCLASSPATH before the ant script invoked 
ant.)
Any clues as to what I need to do to get this working?  I am using Ant 
1.3
and optional.jar 1.3.

----------------

build.xml

  <target name="telnet1">
   <telnet server="ws1" userid="uid" password="passwd">
     <read string="%"/>
     <write>ls</write>
     <read string="%"/>
   </telnet>
  </target>


ant telnet1
----------------

BUILD FAILED

.../samples/ant/ant_again/test2/build.xml:26: Could not create task of 
type:
telnet. Common solutions are to use taskdef to declare your task, or, if
this is an optional task, to put the optional.jar in the lib directory 
of
your ant installation (ANT_HOME).

Total time: 1 second

----------------


Thanks,
Eric




Mime
View raw message