ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Helliwell, Matthew" <Matthew.Helliw...@DRKW.com>
Subject RE: tarfileset not working: solved
Date Thu, 26 Jul 2001 12:46:09 GMT
After a bit of hacking about with the source code, the problem turns out to
be nothing more than that it can't find release.ksh. Doh.

In my defence, the file was present and but with a capital 'R' at the front
and I'm on NT so I was convinced  could see the file!

-- 
Matt


-----Original Message-----
From: Helliwell, Matthew 
Sent: 26 July 2001 09:29
To: 'ant-user@jakarta.apache.org'
Subject: tarfileset not working


Like a few other people I've had problems with the tarfileset and so
downloaded the latest Tar.java to try that. I've still got a problem. Using
this build file

<?xml version="1.0" ?>
<project name="SCARE" default="Build">
    <target name="Build">
        <tar tarfile="${target.dir}/scare.tar">
            <tarfileset dir="${target.dir}/DatabaseLoaderConfigs"
includes="release.ksh"/>
        </tar>
    </target>
</project>

Gives this output

$ ant -verbose -Dtarget.dir=c:/cygwin/home/helliwm/release -buildfile
test.xml
Ant version 1.3 compiled on March 2 2001

Buildfile: test.xml
Detected Java Version: 1.3
Detected OS: Windows NT
parsing buildfile c:\cygwin\home\helliwm\dev\cvsdata\scare\test.xml with URI
= file:c:/cygwin/home/helliwm/dev/cvsdata/scare/test.xml
Project base dir set to: C:\cygwin\home\Helliwm\dev\cvsdata\scare
Build sequence for target `Build' is [Build]
Complete build sequence is [Build]

Build:
      [tar] Nothing to do: C:\cygwin\home\helliwm\release\scare.tar is up to
date.

BUILD SUCCESSFUL

Total time: 1 second

Before the run target.dir is empty apart from
DatabaseLoaderConfigs/release.ksh

After the run its still the same.

I've recompiled Tar.java will a new log message in it to make sure I was
picking up the new version and I am. Anybody any suggestions? Am I just
doing something stupid?

Thanks

-- 
Matt


----------------------------------------------------------------------
If you have received this e-mail in error or wish to read our e-mail 
disclaimer statement and monitoring policy, please refer to 
http://www.drkw.com/disc/email/ or contact the sender.
----------------------------------------------------------------------

Mime
View raw message